httpd-apreq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Steve Hay <steve....@uk.radan.com>
Subject Re: need your help to test mod_perl with perl-5.8.1-RC3
Date Fri, 01 Aug 2003 08:25:10 GMT
Steve Hay wrote:

> Michael G Schwern wrote:
>
>
>>
>> If I could see the Makefiles from 6.03 and 6.12 I might be able to 
>> figure out
>> what's different.  Also, if you could try various alpha versions between
>> those two, show the Makefiles and whether or not they exhibited the
>> behavior that would help alot in narrowing it down.
>>  
>>
> I've also tried MM 6.05: that works OK.
>
> Attached are the various Makefiles (the top-level one, plus those from 
> the c, Cookie and Request sub-directories), and a transcript of the 
> "nmake" step, from a build using MM 6.05 (which worked) and another 
> build using MM 6.12 (which failed).
>
> I'll move on to trying out those alpha versions and get back to you on 
> which was the first one that failed.

This bug evidently goes back a long way:  MM 6.06_02 fails in the same 
way as 6.13.

I tried to use MM 6.06_01, but it wouldn't build itself ("don't know how 
to make 'C:\perl5\libNAME'").  Instead, I knife-and-forked it into 
place, but when I tried to use it to build libapreq, I just got the same 
error again - "don't know how to make 'C:\perl5\libNAME'".

So the best I can offer you at this stage is that something between 6.05 
and 6.06_02 broke it.  (Probably not what you wanted to hear, I guess, 
looking at the number of changes in 6.06_01.)

Steve


Mime
View raw message