httpd-apreq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Steve Hay <steve....@uk.radan.com>
Subject Re: need your help to test mod_perl with perl-5.8.1-RC3
Date Thu, 31 Jul 2003 13:55:57 GMT
Stas Bekman wrote:

> Stas Bekman wrote:
>
>> Steve Hay wrote:
>>
>>> Stas Bekman wrote:
>>>
>>>> Here is what happens:
>>>>
>>>> MM 6.03 used to create libapreq.a but not libapreq.so, libapreq.a 
>>>> was just a by product and never was intented to be installed. 
>>>> Request.so was statically linking libapreq.a into it.
>>>>
>>>> Now with 6.12 it creates both libapreq.so and libapreq.so, so when 
>>>> Request.so is linked, it links libapreq.so dynamically, and of 
>>>> course it can't resolve it later when loading.
>>>>
>>>> This patch fixes things for me in libapreq and works with MM 6.03 
>>>> and 6.12. Steve, please confirm that it works for you and I'll 
>>>> commit it. 
>>>
>>>
>>>
>>>
>>> No, it doesn't fix it :-(
>>>
>>> My problem sounds a little different to yours.  You talk above about 
>>> "... when Request.so is linked...", but my build process doesn't get 
>>> that far.
>>>
>>> Under MM 6.03 it used to build libapreq.lib, then Request.dll then 
>>> Cookie.dll.
>>> Now, under MM 6.12, it builds libapreq.lib, then falls over 
>>> ("boot_libapreq" unresolved) when trying to build libapreq.dll.
>>
>>
>>
>> I think the cause is the same. MM 6.12 builds the shared object of 
>> libapreq (dll in your case and .so in mine), and it didn't use to do 
>> that.
>
>
> OK, try this patch: 

No, still doesn't fix it :-(

Doesn't seem to make any difference, actually.  It still tries to build 
libapreq.dll, and still fails in the same way.  I've attached the 
c/Makefile that was generated by the patched c/Makefile.PL (which should 
have skipped the dynamic_* bits, but seems not to have done).

Steve

Mime
View raw message