httpd-apreq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stas Bekman <s...@stason.org>
Subject Re: latest CVS build & test errors
Date Thu, 24 Jul 2003 12:43:00 GMT
Carl Brewer wrote:
> 
> 
> Some more on this.  httpd starts with the generated httpd.conf file
> ok :
> 
> /tmp/apache2/bin/httpd -f /data/src/httpd-apreq-2/env/t/conf/httpd.conf
> 
> Works fine with httpd compiled with --enable-ipv6
> 
> It answers dumb queries on ::1 :
> 
> steel1: {624} telnet localhost 8529
> Trying ::1...
> Connected to localhost.
> Escape character is '^]'.
> GET stuffed
> <!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
> <html><head>
> <title>400 Bad Request</title>
> </head><body>
> <h1>Bad Request</h1>
> <p>Your browser sent a request that this server could not understand.<br />
> </p>
> </body></html>
> Connection closed by foreign host.
> 
> 
> So I suspect the problem is in the test script.  On NetBSD 1.6.1
> (and a few other O/S's that I know but haven't tested on yet)
> localhost will default to ::1, *not* 127.0.0.1.  I don't know
> if this will be confusing the test harness?
> 
> Anyway, I can't see where the actual tests get done quickly enough to
> make a difference, so that's my bug reporting for the evening :)

If I remember correctly, Philippe has added a support for ipv6 in the latest 
cvs of Apache::Test. Philippe have you seen this problem?


-- 


__________________________________________________________________
Stas Bekman            JAm_pH ------> Just Another mod_perl Hacker
http://stason.org/     mod_perl Guide ---> http://perl.apache.org
mailto:stas@stason.org http://use.perl.org http://apacheweek.com
http://modperlbook.org http://apache.org   http://ticketmaster.com


Mime
View raw message