httpd-apreq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stas Bekman <s...@stason.org>
Subject Re: [apreq-2] Apache::Test preinstall issues
Date Sun, 20 Jul 2003 19:14:54 GMT
Joe Schaefer wrote:
> Stas Bekman <stas@stason.org> writes:
> 
> [...]
> 
> 
>>Actually, this is not a bug, I have done this on purpose, for 3rd
>>party modules which install their modules into Apache2/. use Apache2;
>>should come after local blib so it'll pick these subdirs.
> 
> 
> I don't think so.  Remember C<use lib 'foo'> is essentially
> 
>   BEGIN { unshift @INC, "foo"; }
> 
> so you want the C<use lib> directives in modperl_inc.pl to come *after* 
> the C<use Apache2> directive.  Otherwise the first item in @INC will 
> be something like
> 
>   /usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi/Apache2
> 
> which will completely *ignore* the local blib/lib if there's a prior
> install.

Not at all. Once you have blib/lib/Apache2 and blib/arch/Apache2, they will 
come in first in @INC and there is no problem.

>>On the contrary Apache::Request 2 build is broken in that respect. It
>>installs into @INC, and not into Apache2/ making it impossible to have
>>Apache::Request for mp1 and mp2 coexist under the same perl tree. 
> 
> 
> True- we need to fix that as well.

Fixing that will remove the need to provide the workaround you've committed. 
Which I can see you have done already. Now it's the time to revert the workaround.

__________________________________________________________________
Stas Bekman            JAm_pH ------> Just Another mod_perl Hacker
http://stason.org/     mod_perl Guide ---> http://perl.apache.org
mailto:stas@stason.org http://use.perl.org http://apacheweek.com
http://modperlbook.org http://apache.org   http://ticketmaster.com


Mime
View raw message