httpd-apreq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joe Schaefer <joe+gm...@sunstarsys.com>
Subject Re: apreq2 buildconf issues
Date Thu, 12 Jun 2003 04:38:36 GMT
Stas Bekman <stas@stason.org> writes:

[...]

> I can certainly do that. But are you sure that it's a good idea?

As developers, we often make silly demands of one another :-)

> I mean I can do the testing with older versions unless you decide that
> they aren't supported, in which case can require a minimal version and
> assert with a usefull error message if the requirement is not
> satisfied?

It's not about putting "support requirements" on the build system, 
it's about keeping the build system convenient for the developers 
who build it.  We certainly would benefit from having those requirements
made explicit in both buildconf and README.

> Of course this issue is moot if users normally won't need to run automake,
> assuming that you make sure to generate all the necessary files for releases.

Right- the release manager needs to ensure that a ./configure script is
available in the distribution (which reminds me that I didn't remember 
to do that for 1.2_rc2).


-- 
Joe Schaefer

Mime
View raw message