httpd-apreq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chris Devers <cdev...@pobox.com>
Subject Re: errors installing libapreq [RESOLVED]
Date Thu, 26 Jun 2003 15:00:18 GMT
Well, I rebuilt Apache/mod_perl, and it seemed to work. For those that
hit the same error, the fix -- which I've saved as a script for future
reference :) -- is as follows:

* Install Apache/mod_perl:

    #!/bin/sh
    # chd.build.apachemodperl.sh

    perl=/sw/bin/perl
    modperldir=/usr/src/mod_perl-1.27
    apachedir=/usr/src/apache_1.3.27
    builddir=/usr/local/apache

    pushd $modperldir

    $perl Makefile.PL \
        APACHE_SRC=../apache_1.3.xx/src \
        APACHE_PREFIX=${builddir} \
        APACHE_USER=www \
        APACHE_GROUP=www \
        DO_HTTPD=1 \
        USE_APACI=1 \
        EVERYTHING=1 \
        APACI_ARGS='--sbindir=${builddir}/sbin, \
                    --sysconfdir=${builddir}/etc, \
                    --localstatedir=${builddir}/var, \
                    --runtimedir=${builddir}/var/run, \
                    --logfiledir=${builddir}/var/logs, \
                    --proxycachedir=${builddir}/var/proxy, \
                    --enable-module=so'
    make
    make test
    sudo make install

    pushd $apachedir
    sudo make install

    echo "Verifying that the build worked:"
    ${builddir}/sbin/apachectl configtest && \
      echo "congratulations, you may now reset apache by running" && \
      echo "${builddir}/sbin/apachectl start"


* Installation may disrupt Perl modules. I had to rebuild Apache::Test

    % sudo /sw/bin/perl -MCPAN -e shell
    cpan> install Apache::Test


* Install libapreq:

    % perl Makefile.PL \
    > -httpd /usr/local/apache/sbin/httpd \
    > -apxs  /usr/local/apache/sbin/apxs
    % make
    % make test
    % make install


Everything went smoothly up to the `perl Makefile.PL [...]` step, where I
got this error:

    skipping test setup...Undefined subroutine &Apache::Test::config called at /sw/lib/perl5/site_perl/5.8.0/darwin/Apache/TestMM.pm
line 90.
    Warning: prerequisite Apache::Test 1.03 not found. We have unknown version.

And, as I say, rebuilding Apache::Test in the CPAN shell took care of
that. Others may hit different problems that could be fixed similarly.

All better now :)



-- 
Chris Devers    cdevers@boston.com

channeler, n.
Also SPIRIT GUIDE. Politically correct terms for DAEMON.

    -- from _The Computer Contradictionary_, Stan Kelly-Bootle, 1995

Mime
View raw message