httpd-apreq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stas Bekman <s...@stason.org>
Subject Re: apreq2 buildconf issues
Date Thu, 12 Jun 2003 04:09:06 GMT
Joe Schaefer wrote:
> Stas Bekman <stas@stason.org> writes:
> 
> [...]
> 
> 
>>% automake
>>src/Makefile.am:5: invalid variable `nobase_include_HEADERS'
>>
>>% ./configure
>>
>>now succeeds
> 
> 
> [...]
> 
> 
>>% automake --version
>>automake (GNU automake) 1.4-p6
> 
> 
> Ok, now we're getting somewhere:
> 
>   http://www.gnu.org/manual/automake-1.6.1/html_node/automake_23.html
> 
> So you probably need to upgrade your automake package to 1.6:
> 
>   % rpm -q automake
>   automake-1.6.3-1
> 
>   % rpm -q libtool
>   libtool-1.4.2-12

I can certainly do that. But are you sure that it's a good idea? I mean I can 
do the testing with older versions unless you decide that they aren't 
supported, in which case can require a minimal version and assert with a 
usefull error message if the requirement is not satisfied?

Of course this issue is moot if users normally won't need to run automake, 
assuming that you make sure to generate all the necessary files for releases.



__________________________________________________________________
Stas Bekman            JAm_pH ------> Just Another mod_perl Hacker
http://stason.org/     mod_perl Guide ---> http://perl.apache.org
mailto:stas@stason.org http://use.perl.org http://apacheweek.com
http://modperlbook.org http://apache.org   http://ticketmaster.com


Mime
View raw message