httpd-apreq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stas Bekman <s...@stason.org>
Subject Re: apreq2 buildconf issues
Date Wed, 11 Jun 2003 06:52:24 GMT
Joe Schaefer wrote:
> Stas Bekman <stas@stason.org> writes:
> 
> 
>>when running ./buildconf
>>
>>removing stale config files
>>running libtoolize --automake --copy --force
>>running aclocal
>>running autoconf
>>running automake -a -c
>>automake: configure.ac: installing `build/install-sh'
>>automake: configure.ac: installing `build/mkinstalldirs'
>>automake: configure.ac: installing `build/missing'
> 
> 
> Looks good up to here.
> 
> 
>>configure.ac: 193: required file `build/ltmain.sh' not found
> 
> 
> build/ltmain.sh should be generated by automake;

Generated? It's automake that complains about it, how could it be generated by it?

% automake
configure.ac: 193: required file `build/ltmain.sh' not found
src/Makefile.am:5: invalid variable `nobase_include_HEADERS'

> Do you have a stale (deleted from cvs) configure.in
> file in your base directory?

no, I don't have it.

> Also, you might try commenting out
> 
>   AC_CONFIG_AUX_DIR(build)
> 
> (putting "dnl" at the front of the line should work)
> from configure.ac and see if that helps.

done:

% automake
src/Makefile.am:5: invalid variable `nobase_include_HEADERS'

% ./configure

now succeeds

>>configure.ac: 193: installing `build/config.guess'
>>configure.ac: 193: installing `build/config.sub'
>>src/Makefile.am:5: invalid variable `nobase_include_HEADERS'
>>
>>is that OK?
> 
> 
> No, it's probably not OK.  Here's what happens for me:
> 
>   % cvs co httpd-apreq-2
>   % cd httpd-apreq-2
>   % ./buildconf
>   removing stale config files
>   running libtoolize --automake --copy --force
>   running aclocal
>   running autoconf
>   running automake -a -c
>   configure.ac: installing `build/install-sh'
>   configure.ac: installing `build/mkinstalldirs'
>   configure.ac: installing `build/missing'
>   env/Makefile.am: installing `build/depcomp'
>   buildconf successful.
>   %
> 
> What's you're automake version?  Mine's 1.6.3.

% automake --version
automake (GNU automake) 1.4-p6

% libtool --version
ltmain.sh (GNU libtool) 1.4.2 (1.922.2.53 2001/09/11 03:18:52)



__________________________________________________________________
Stas Bekman            JAm_pH ------> Just Another mod_perl Hacker
http://stason.org/     mod_perl Guide ---> http://perl.apache.org
mailto:stas@stason.org http://use.perl.org http://apacheweek.com
http://modperlbook.org http://apache.org   http://ticketmaster.com


Mime
View raw message