httpd-apreq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Wheeler <da...@wheeler.net>
Subject Re: apreq-1 & apreq-2 status updates
Date Mon, 16 Jun 2003 02:35:14 GMT
On Sunday, June 15, 2003, at 08:36  AM, Joe Schaefer wrote:

>   b) David Wheeler reports that the new test
>      suite is failing on OSX, although libapreq-1.2
>      seems to be working ok for him.  In lieu of a
>      working fix for the tests, I'd be happy to
>      apply a doc patch for README.MacOSX that
>      talks about this problem.

Well, I just downloaded and build it again, and all the tests passed. 
Beats me what the problem might have been, but I would say that you're 
good to go now.

However, with the latest version of Apache::Test installed from CVS and 
mod_perl 1.27's old Apache::test in @INC before Apache::Test, I get 
this error:

Undefined subroutine &Apache::Test::vars called at 
/usr/local/lib/perl5/site_perl/5.8.0/Apache/TestRequest.pm line 142.

You might want to warn Mac OS X users about the 
Apache::Test/Apache::test problem. Or Stas might want to get a new 
version of Apache::Test out that fixes it.

>      btw- Can we get rid of that comment in the
>      BUGS section of Cookie.pm that talks about
>      Apache::Cookie not running on OSX?

Definitely.

Regards,

David

-- 
David Wheeler                                     AIM: dwTheory
david@kineticode.com                              ICQ: 15726394
http://kineticode.com/                         Yahoo!: dew7e
                                                Jabber: Theory@jabber.org
Kineticode. Setting knowledge in motion.[sm]


Mime
View raw message