httpd-apreq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Randy Kobes <ra...@theoryx5.uwinnipeg.ca>
Subject Re: [apreq-2] win32 workarounds
Date Sun, 04 May 2003 18:46:28 GMT
On 4 May 2003, Joe Schaefer wrote:

> Randy Kobes <randy@theoryx5.uwinnipeg.ca> writes:
> [...]
> > For the first problem, mod_perl 2, for example, doesn't use
> > APR_INLINE on Win32. I'm not sure about the 2nd problem ...
> > Would the following be OK, just to let things compile on
> > Win32, and then come back to this later?
> 
> +1, please apply the patch.

OK, thanks. I will come back to this later ....
> 
> [...]
> 
> > With this, the library builds, and the testall test can be
> > run (this presently fails 3 of the performance tests).
> 
> Hmm, there's only 3 active performance tests right now :-(
> Can you post the output of
> 
>   % t/testall -v

OK - I get

All APREQ Tests:
    Table:                    .............
    Cookie:                   ....
    Param:                    ..
    Parsers:                  ..
    Performance:              FFF

24 tests run:  21 passed, 3 failed, 0 not implemented.

Failed tests in Performance:
1) perf_init: apr_hash should win: APR = 13.019 vs 
   APREQ = 9.013 (microseconds)
2) perf_get_avg: apreq should win (8): APR = 0.000 vs 
   APREQ = 1.001 (microseconds)
3) perf_get: apr_table_get(Accept-Language) wins: APR = 0.000 vs 
   APREQ = 1.001 (microseconds)

Maybe it's a problem with timing things in Win32? I'll
take a closer look ... Actually, I'm glad I got these
failures, as before they were all passing consistently,
and I started to worry that there was something wrong :)

-- 
best regards,
randy


Mime
View raw message