httpd-apreq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joe Schaefer <...@sunstarsys.com>
Subject Re: cvs commit: httpd-apreq/Request Request.xs
Date Mon, 14 Apr 2003 03:26:51 GMT
Stas Bekman <stas@stason.org> writes:

> Joe Schaefer wrote:
> [...]
> > However, the whole patch really bothers me.  What I'm
> > attempting to do is revert to the original upload->fh code for pre-5.8 perls,
> > because *rumor has it* that the newer code freaks out on certain platforms.
> > However, *I* haven't encountered such problems on the pre-5.8 server that I
> > have access to (perl 5.6.1 + mod_perl 1.26 + apache 1.3.27).
> > I'm reluctant to push for a 1.2 release until I've
> >   1) seen evidence that the 1.1 upload code actually misbehaves
> >      somewhere.
> >   2) seen evidence that the problem disappears when the old
> >      upload->fh code is used in it's place (which is what
> >      current-cvs is supposed to do).
> 
> The test suite needs to expose the problem on these 'certain platform'.

Absolutely!  I've been tinkering with the upload test in
t/apreq/request.t to tickle out the bug, but no luck so far.

> What platforms are we talking about? What freaks out? Do we have these issues

If you recall the 1.1 post-release discussion we had (in late January) 
on the mod_perl user list, Matt Sergeant reported zombies appearing on

  perl 5.00503 on RH 6.2 and mod_perl 1.26

when he installed 1.1.  I haven't been able to reproduce that behavior
on my RH 7.2-based setup (described above), but I don't doubt that his
zombies were produced by the v1.1 upload code in Request.xs.

-- 
Joe Schaefer

Mime
View raw message