httpd-apreq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Wheeler <da...@wheeler.net>
Subject Re: libapreq-1.2 release candidate
Date Wed, 30 Apr 2003 18:09:02 GMT
On Wednesday, April 30, 2003, at 12:33  PM, Joe Schaefer wrote:

>> Tested OK for me (on Windows XP / Perl 5.8.0 / Apache 1.3.27 /
>> mod_perl 1.27).
>
> That's great news!

Not so well for me on Mac OS X. There are a couple of issues.

1. It seemed to get confused about the presence of Apache::Test. I have 
the old Apache::test installed on my system, and might even have some 
old version of Apache::Test. So I got this error:

Can't locate Apache/TestMM.pm in @INC (@INC contains: Apache-Test/lib 
/usr/local/bricolage/lib /Users/david/dev/perl/myco/classes 
/usr/local/lib/perl5/5.8.0/darwin /usr/local/lib/perl5/5.8.0 
/usr/local/lib/perl5/site_perl/5.8.0/darwin 
/usr/local/lib/perl5/site_perl/5.8.0 /usr/local/lib/perl5/site_perl .) 
at Makefile.PL line 16.

When I ran CPANP and told it to install Apache::Test, it too thought I 
was up to date. then I told it to install Apache::TestMM, and then it 
did the right thing. So it might make more sense to have the test in 
Makefile.PL test for TestMM, instead:

use constant HAS_APACHE_TEST => eval {require Apache::TestMM};

Once I had Apache::TestMM properly installed, I was able to run "perl 
Makefile.PL" and make, and all went well. But then for "make test", I 
got this error:

/usr/local/bin/perl -Iblib/arch -Iblib/lib \
t/TEST -clean
Can't open perl script "t/TEST": No such file or directory
make: *** [test_clean] Error 2

I'm not sure why this is, but it looks like since 
Apache::test->get_test_params() is commented out, it would never know 
where to find the binary. Um, but on the other hand, running perl 
Makefile.PL again, I see this warning:

skipping test setup...Undefined subroutine &Apache::Test::config called 
at /usr/local/lib/perl5/site_perl/5.8.0/Apache/TestMM.pm line 90.

Since config() is clearly defined in Apache::Test, I'm not sure what 
the problem there is.

Anyway, I ran make install and that went fine, and then, firing up 
Bricolage, it seems to work fine. So I expect that there are just some 
configuration tweaks that need to be made, or maybe it's just some 
funkyness on my box.

Anyway, here's a patch for INSTALL.MacOSX that adds in the requirement 
for Apache::TestMM.

--- INSTALL.MacOSX      Wed Apr 30 13:08:24 2003
+++ INSTALL.MacOSX.new  Wed Apr 30 13:00:12 2003
@@ -24,7 +24,7 @@
  and then "sudo make install" to install the C library.

  Next, the normal Perl build of libapreq should work. Note that you'll 
need
-libwwwperl and URI installed in order to run make test.
+Apache::TestMM, libwwwperl, and URI installed in order to run "make 
test".

  % perl Makefile.PL
  % make

Regards,

David

-- 
David Wheeler                                     AIM: dwTheory
david@kineticode.com                              ICQ: 15726394
                                                Yahoo!: dew7e
                                                Jabber: Theory@jabber.org
Kineticode. Setting knowledge in motion.[sm]


Mime
View raw message