httpd-apreq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Randy Kobes <ra...@theoryx5.uwinnipeg.ca>
Subject Re: Makefile.PL patch for compilation on HP-UX
Date Thu, 06 Feb 2003 02:06:40 GMT
On Thu, 6 Feb 2003, Stas Bekman wrote:

> Index: Makefile.PL
> ===================================================================
> RCS file: /home/cvs/httpd-apreq/Makefile.PL,v
> retrieving revision 1.17
> diff -u -r1.17 Makefile.PL
> --- Makefile.PL	24 Dec 2002 06:45:04 -0000	1.17
> +++ Makefile.PL	5 Feb 2003 22:33:11 -0000
> @@ -3,6 +3,16 @@
>   use FindBin;
>   use 5.005;
> 
> +use File::Path qw(mkpath);
> +
> +use mod_perl;

Or perhaps 'require mod_perl', so that the 'die' statements below
have a chance to give an informative message? Or even wrap it in
an eval, so that if mod_perl's not present, a suitable message
can be given?

> +if ($mod_perl::VERSION < 1.2402) {
> +    die "Please upgrade mod_perl to 1.24_02 or greater";
> +}
> +elsif ($mod_perl::VERSION > 1.98) {
> +    die "mod_perl 1.x is required";
> +}
> +

-- 
best regards,
randy


Mime
View raw message