httpd-apreq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Randy Kobes <ra...@theoryx5.uwinnipeg.ca>
Subject Re: Makefile.PL patch for compilation on HP-UX
Date Wed, 05 Feb 2003 20:53:50 GMT
On Wed, 5 Feb 2003, Monin, Jeremy wrote:

> While installing libapreq-1.1 with Perl 5.6 on an HP-UX
> 11.00 system, I found that Makefile.PL was looking for
> Apache::MyConfig inside if ($Is_Win32) {} .  My system doesn't
> have Apache::MyConfig, which would not be a problem, it's
> looking for this module inside the if statement.  But since we
> have "use" instead of "require", this module request is
> interpreted at compile time, not runtime - it looks for
> Apache::MyConfig, regardless of $Is_Win32.  The patch below
> corrects this.

Although Apache::MyConfig isn't used here if not on Win32, it was
my understanding that the build of libapreq required mod_perl to
be installed (eg, for Apache::src, to find the Apache headers),
and so this shouldn't normally be a problem. Do you have mod_perl
installed? And if so, what version?

-- 
best regards,
randy kobes


Mime
View raw message