httpd-apreq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tomo <shelty_...@yahoo.com>
Subject Re: libapreq for C only tests
Date Wed, 18 Dec 2002 15:20:09 GMT
Ok
I had first tried compiling them but didn't know to link them.
For example I used the ldap api and linked it with: '-lldap' flag.

What flag do I need to link libareq properley?

I thought it may be a linker problem...
# ld -G -o mod_teldir.so mod_teldir.o -lldap -lapreq
ld: fatal: library -lapreq: not found
ld: fatal: File processing errors. No output written to mod_teldir.so

Thanks, for you help.

Regards,
Tomo
--- "David N. Welton" <davidw@dedasys.com> wrote:
> Tomo <shelty_dog@yahoo.com> writes:
> 
> > "You aren't compiling in the apache_request* stuff."  I did not
> > compile anything when untaring the package.  Can you give me more
> > detail or example of the meaning?
> 
> I took the C sources, put them in the directory where I needed them,
> and compiled them, together with my other files that I wrote.  At
> that
> point, I use the linker to make a loadable shared object (.so) out of
> the whole mess.  Don't bother with the apreq build system, use your
> "own".
> 
> -- 
> David N. Welton
>    Consulting: http://www.dedasys.com/
>      Personal: http://www.dedasys.com/davidw/
> Free Software: http://www.dedasys.com/freesoftware/
>    Apache Tcl: http://tcl.apache.org/


__________________________________________________
Do you Yahoo!?
Yahoo! Mail Plus - Powerful. Affordable. Sign up now.
http://mailplus.yahoo.com

Mime
View raw message