httpd-apreq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sven Geisler <sgeis...@aeccom.com>
Subject Re: segfaults with libaprep1.1 and perl 5.8
Date Fri, 20 Dec 2002 16:56:21 GMT
Hi Joe,

I try to get core dumps. But I didn't find core dumps after a segfault.
Has anyone a idea?

Sven.


Am Don, 2002-12-19 um 18.11 schrieb Joe Schaefer:
> Sven Geisler <sgeisler@aeccom.com> writes:
> 
> > Hi Joe,
> > 
> > I would like to support you and fix the problem. 
> > "What can I do?" means also how can I find the bug, are there hidden
> > information to this kind of segfault? 
> 
> It's tricky-  search the mod_perl list's archive (~8 months ago?) for
> a conversation between Doug MacEachern and Andrew Koenig
> regarding these segfaults.  Their discussion is also on 
> the perl5.porters list (IIRC, the p5p discussion has more info
> than the mod_perl archives).  This segfault was affecting
> PAUSE; I don't know how Mr. Koenig resolved it.
> 
> Doug put together a few patches, and I applied one of them to apreq
> last month, but I don't know if it was the correct fix.
> 
> Please keep the apreq-dev list informed regarding your progress.
> It'd really help if you posted the particulars of your situation
> to apreq-dev, so at least we'd have a detailed record.  If you've 
> compiled perl5.8.0 with ithread support, you might try disabling
> that and see if the segfaults disappear.
> 
> Good luck, and thanks for the help!
> 
> -- 
> Joe Schaefer
> 



Mime
View raw message