httpd-apreq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Steve Murphy <m...@e-tools.com>
Subject Can't build libapreq-1.0
Date Wed, 11 Dec 2002 04:34:22 GMT
Hello--

I'm trying to configure and build libapreq-1.0 on a solaris box.

I've installed without problem mod_perl-1.99_07; perl-5.8.0; and
apache-2.0.43.

When I try to do a perl Makefile.PL, I get 

Can't locate Apache/MyConfig.pm in @INC (@INC contains:
/usr/local/lib/perl5/5.8.0/sun4-solaris /usr/local/lib/perl5/5.8.0
....blah, blah

So, I try the ./configure \
                   --with-apache-includes=/usr/local/apache2/include


and when I do a make, I get to apache_cookie.h, the first error of many:

...
apache_request.h:38: parse error before 'table'

It appears that it expects to already have the type 'table' defined, but
it is not. I couldn't find a likely typedef anywhere.

How do should I be building this beast?

murf


-- 
Steve Murphy <murf@e-tools.com>
Electronic Tools Company

Mime
View raw message