httpd-apreq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stas Bekman <s...@stason.org>
Subject Re: 1.x tests working in cvs
Date Sun, 24 Nov 2002 09:09:33 GMT
Joe Schaefer wrote:
> I've moved the modperl-1.x cookie-request tests over to t/.
> The normal process
> 
>   % perl Makefile.PL
>   % make
>   % make test
> 
> should run the tests (successfully) everywhere except for OS X.
> There may be tons of warnings right now, but the tests should 
> run to completion.

Apparently, Apache::test setup doesn't look in the local dir first when 
loading Apache::Request. I've had an older A::Request installed and I 
was getting:

t/httpd -f `pwd`/t/httpd.conf
Syntax error on line 31 of /home/stas/apache.org/httpd-apreq/t/httpd.conf:
Apache::Request object version 1.0 does not match bootstrap parameter 
1.1 at 
/home/stas/perl/ithread/lib/5.8.0/i686-linux-thread-multi/DynaLoader.pm 
line 249.
Compilation failed in require at (eval 16) line 3.

If I'm running 'make install' and then test, it's ok:
t/cookie.....ok
t/request....ok
All tests successful.
Files=2, Tests=50,  5 wallclock secs ( 1.29 cusr +  0.08 csys =  1.37 CPU)
kill `cat t/httpd.pid`


__________________________________________________________________
Stas Bekman            JAm_pH ------> Just Another mod_perl Hacker
http://stason.org/     mod_perl Guide ---> http://perl.apache.org
mailto:stas@stason.org http://use.perl.org http://apacheweek.com
http://modperlbook.org http://apache.org   http://ticketmaster.com


Mime
View raw message