httpd-apreq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stas Bekman <s...@stason.org>
Subject Re: 5.8.0 is out; need new Request.xs?
Date Fri, 19 Jul 2002 21:12:53 GMT
Joe Schaefer wrote:
> Has anybody tried running the apreq-1 test suite in cvs
> against 5.8.0 yet?  I'm told it fails.

confirmed, it's messed up a bit. it seems that there is some problem 
with apxs. but otherwise it works fine.

The following works as a temp workaround for DSO and non-DSO mod_perl:

% perl5.8.0 Makefile.PL -apxs /home/httpd/httpd_perl/bin/apxs
% make
% t/TEST -httpd /home/httpd/httpd_perl/bin/httpd
apreq/big_input....ok
apreq/cookie.......ok
apreq/request......ok
All tests successful.

I don't think there is any problem with perl 5.8.0. at least not with my 
build, which is:
./Configure -des -Dusethreads -Doptimize='-g' -Duseshrplib -Dusedevel
uname -a:
Linux hope.stason.org 2.4.18-6mdksmp #1 SMP Fri Mar 15 01:24:36 CET 2002 
i686 unknown

It's too late and my brain malfunctions and tomorrow I'm catching a 
plane to San Diego. So I'll look at it probably after the conference. or 
may be during it if I get a chance, unless somebody beats me to it.

__________________________________________________________________
Stas Bekman            JAm_pH ------> Just Another mod_perl Hacker
http://stason.org/     mod_perl Guide ---> http://perl.apache.org
mailto:stas@stason.org http://use.perl.org http://apacheweek.com
http://modperlbook.org http://apache.org   http://ticketmaster.com


Mime
View raw message