httpd-apreq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joe Schaefer <joe+apa...@sunstarsys.com>
Subject Re: autoconf support?
Date Thu, 21 Feb 2002 04:34:29 GMT
Jim Winstead <jimw@apache.org> writes:

> On Wed, Feb 20, 2002 at 07:55:22PM -0500, Joe Schaefer wrote:
> > It seems to me that all we're really missing is some 
> > 
> >   -version-info 1:0:0 
> > 
> > setting somewhere.
> 
> okay, i added it and updated the tarball at
> http://www.apache.org/~jimw/libapreq-1.0.tar.gz

+1 !!!

All modperl tests passed using the standard perl build process.  

One issue that we may want to address now, or perhaps in a future 
release- installing the shared libapreq libraries using ./configure 
caused a "problem" when I subsequently installed the perl way.  What 
happened is that Request.so and Cookie.so got linked against the
installed libapreq.so version, NOT the libapreq.a file.  When preloading 
Apache::Request, I got the following error:

  Can't load '[...]/auto/Apache/Request/Request.so' for module 
  Apache::Request: libapreq.so.1: cannot open shared object file: 
  No such file or directory at [...]/DynaLoader.pm line 169.

I ran ldd on Request.so, and sure enough it linked 
against /usr/local/lib/libapreq.so.1.0.0 instead of the 
static libapreq.a.  So next I ran ldconfig to get rid of the
above error, and ran the modperl tests again, and everything
passed!

This may give Mac OS/X users a simpler approach to solving their
dynaloading problem with Apache::Cookie and Apache::Request.

-- 
Joe Schaefer

Mime
View raw message