httpd-apreq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joe Schaefer <...@sunstarsys.com>
Subject Re: bleedperl problems
Date Mon, 11 Jun 2001 22:15:07 GMT
Geoffrey Young <gyoung@laserlink.net> writes:

> ok - I'll have to rebuild 5.6.1 though, so it may take me a while.  my 5.6.1
> build using
> 
> config_args='-des -Dusethreads -Doptimize=-g -Dusedevel'
> 
> gave me useperlio=undef and usemultiplicity=defined
> 
> anyway, I'll get to it soonish and report back...
> 

Don't worry about testing PerlIO on linux- I just built another perl
and tried it out- no problems with the modperl tests.  Perhaps it 
would be better if you tried it using your original config flags and 
built against a stable perl.

Here is the build info for the latest successful test:

  mod_perl 1.25-01 (cvs)
  apache 1.3.20

  % perl -V
  Summary of my perl5 (revision 5.0 version 6 subversion 1) configuration:
  Platform:
    osname=linux, osvers=2.2.13, archname=i586-linux-perlio
    uname='linux mumonkan.sunstarsys.com 2.2.13 #12 sat dec 25 02:26:36 est 1999 i586 unknown
'
    config_args=''
    hint=previous, useposix=true, d_sigaction=define
    usethreads=undef use5005threads=undef useithreads=undef usemultiplicity=undef
    useperlio=define d_sfio=undef uselargefiles=define usesocks=undef
    use64bitint=undef use64bitall=undef uselongdouble=undef
  Compiler:
    cc='cc', ccflags ='-DDEBUGGING -fno-strict-aliasing -I/usr/local/include -I/usr/gnu/include
-D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64',
    optimize='-g',
    cppflags='-DDEBUGGING -fno-strict-aliasing -I/usr/local/include -I/usr/gnu/include -D_LARGEFILE_SOURCE
-D_FILE_OFFSET_BITS=64'
    ccversion='', gccversion='2.96 20000731 (Red Hat Linux 7.0)', gccosandvers=''
    intsize=4, longsize=4, ptrsize=4, doublesize=8, byteorder=1234
    d_longlong=define, longlongsize=8, d_longdbl=define, longdblsize=12
    ivtype='long', ivsize=4, nvtype='double', nvsize=8, Off_t='off_t', lseeksize=8
    alignbytes=4, usemymalloc=n, prototype=define
  Linker and Libraries:
    ld='cc', ldflags =' -L/usr/local/lib -L/usr/gnu/lib'
    libpth=/usr/local/lib /usr/gnu/lib /lib /usr/lib
    libs=-lnsl -lndbm -lgdbm -ldl -lm -lc -lposix -lcrypt -lutil
    perllibs=-lnsl -ldl -lm -lc -lposix -lcrypt -lutil
    libc=/lib/libc-2.1.92.so, so=so, useshrplib=false, libperl=libperl.a
  Dynamic Linking:
    dlsrc=dl_dlopen.xs, dlext=so, d_dlsymun=undef, ccdlflags='-rdynamic'
    cccdlflags='-fpic', lddlflags='-shared -L/usr/local/lib -L/usr/gnu/lib'


-- 
Joe Schaefer


Mime
View raw message