httpd-apreq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Thorsteinn Sigurdsson" <tsigurds...@tnsn.com>
Subject [H] timeout when uploading files.
Date Fri, 22 Jun 2001 10:59:03 GMT
Hi,
I'm trying to upload a file to my web server and am getting alot of odd
behavior.
The form I use is:
<FORM NAME="upfile" ACTION="/mailshots.epl" ENCTYPE="multipart/form-data"
METHOD="post">
<INPUT TYPE="file" NAME="oFile1"><br>
<INPUT TYPE="submit" VALUE="Upload File">
</FORM>

The code I use is the usual:
use Apache::Request;
#$r = shift;
my $apr = Apache::Request->new($r);
my $upload = $apr->upload;

if ($upload) {
my $fh = $upload->fh;
while (<$fh>) { my $bla = $_; }
close $fh;
}

When I try to use $r = shift I get:
[Thu Jun 21 19:04:47 2001] [notice] child pid 26250 exit signal Segmentation
fault (11)
And I start to get The page cannot be displayed. Skipping it seems to be
ok...

When I send a file the client times out and I get this message in the
error_log:
Fri Jun 22 11:36:24 2001] [info] [client 192.168.0.150]
multipart_buffer_fill timed out
Also I start to get missing pages again although there is no segmentation
fault.

I have two servers and I've tried the file_upload.pl script on both of them
and it complaints about unexpected end of headers.

Any ideas of what could be wrong.

Regards,
Thorsteinn Sigurdsson (tsigurdsson@tnsn.com)
The National Solicitor's Network
73, Gloucester Road
SW7 4SS, London, UK
Tel: 2027 2446422 - Fax: 0207 3706893 - GSM: 0794 9038206


Mime
View raw message