httpd-apreq-cvs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From pgollu...@apache.org
Subject svn commit: r434368 - /httpd/apreq/trunk/build/version_check.pl
Date Thu, 24 Aug 2006 10:20:58 GMT
Author: pgollucci
Date: Thu Aug 24 03:20:49 2006
New Revision: 434368

URL: http://svn.apache.org/viewvc?rev=434368&view=rev
Log:
at the moment autconf 2.60 breaks

glue/perl/Makefile.PL messes with autoconf internals, reading
config.status and trying to read PACKAGE_VERSION (among other variables)
from there.  For some reason, "|#_!!_#|" is prepended there.  Then, gcc
is called with -DVERSION=\"|#_!!_#|2.08\" -- pipes and exclamation marks
(and probably hashes) are interpreted by shell.

Similar issue has been discussed on the bug-autoconf list:
http://lists.gnu.org/archive/html/bug-autoconf/2006-06/msg00127.html

Reported by: pgollucci
Verified by: Radoslaw Zielinski <radek@pld-linux.org>


Modified:
    httpd/apreq/trunk/build/version_check.pl

Modified: httpd/apreq/trunk/build/version_check.pl
URL: http://svn.apache.org/viewvc/httpd/apreq/trunk/build/version_check.pl?rev=434368&r1=434367&r2=434368&view=diff
==============================================================================
--- httpd/apreq/trunk/build/version_check.pl (original)
+++ httpd/apreq/trunk/build/version_check.pl Thu Aug 24 03:20:49 2006
@@ -47,7 +47,7 @@
 
 my %svn = (
                 libtool => { version => "1.4.3",   test => \&gnu_version },
-               autoconf => { version => "2.53",    test => \&gnu_version },
+               autoconf => { version => "2.53",    test => \&gnu_version, broken_version
=> '2.60' },
                automake => { version => "1.6.1",   test => \&gnu_version },
                 doxygen => { version => "1.2",     test => \&gnu_version, broken_version
=> '1.4.5' },
                    perl => { version => "5.6.1",   test => \&gnu_version },



Mime
View raw message