httpd-apreq-cvs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From j...@apache.org
Subject cvs commit: httpd-apreq Changes INSTALL
Date Sun, 05 Jan 2003 13:06:52 GMT
joes        2003/01/05 05:06:52

  Modified:    .        Changes INSTALL
  Log:
  Minor doc updates.
  
  Revision  Changes    Path
  1.42      +6 -0      httpd-apreq/Changes
  
  Index: Changes
  ===================================================================
  RCS file: /home/cvs/httpd-apreq/Changes,v
  retrieving revision 1.41
  retrieving revision 1.42
  diff -u -r1.41 -r1.42
  --- Changes	5 Nov 2002 16:35:02 -0000	1.41
  +++ Changes	5 Jan 2003 13:06:51 -0000	1.42
  @@ -2,6 +2,12 @@
   
   =over 4
   
  +=item 1.05 - January 5, 2002
  +
  +Include patch and supporting documentation for OS X [David Wheeler].
  +Temporarily revert test suite to Apache::test. [Joe Schaefer]
  +Updated Request.xs to avoid some segfaults in perl 5.8 (partial fix).
  +
   =item 1.04 - November 5, 2002
   
   Replace autogenerated files with BUILD.sh script. 
  
  
  
  1.5       +33 -2     httpd-apreq/INSTALL
  
  Index: INSTALL
  ===================================================================
  RCS file: /home/cvs/httpd-apreq/INSTALL,v
  retrieving revision 1.4
  retrieving revision 1.5
  diff -u -r1.4 -r1.5
  --- INSTALL	30 Apr 2002 07:17:26 -0000	1.4
  +++ INSTALL	5 Jan 2003 13:06:51 -0000	1.5
  @@ -1,3 +1,22 @@
  +****************************************************
  +* NOTE TO OS X users- PLEASE READ THE INSTALLATION *
  +* INSTRUCTIONS IN INSTALL.MacOSX                   *
  +****************************************************
  +
  +--------------------------------------------------
  +IMPORTANT NOTE: To install the Perl modules, your 
  +mod_perl installation MUST includes support for 
  +Apache::Table.  This means that mod_perl should
  +be built using the EVERYTHING=1, or at minimum 
  +PERL_TABLE_API=1.  If you see errors like this 
  +(during compilation of libapreq)
  +
  +  Error: 'Apache::Table' not in typemap in Request.xs,
  +
  +your mod_perl must be rebuilt to include Apache::Table 
  +support.
  +--------------------------------------------------
  +
   To install the Perl and C libraries, simply run:
   
    perl Makefile.PL && make && make test && make install
  @@ -16,7 +35,19 @@
   
    perl Makefile.PL -httpd /path/to/apache/bin/httpd
   
  -To build libapreq without the Makefile.PL, run:
  +--------------------------------------------------
  +
  +Alternatively, to build and install a shared version 
  +of libapreq using GNU libtool, do this:
   
  - ./configure [--with-apache-includes=DIR] && make
  + ./configure --with-apache-includes=DIR && make && make install
   
  +Note: The mod_perl API (Apache::Request and Apache::Cookie) will
  +link against this version of libapreq if it is available.  That
  +means if you're upgrading from an older version of libapreq.so, 
  +that was installed using this "./configure" method, you may need 
  +to upgrade the old library installation PRIOR to building Request.so
  +and Cookie.so:
  +
  + ./configure --with-apache-includes=DIR && make && make install
  + perl Makefile.PL && make && make test && make install
  
  
  

Mime
View raw message