htrace-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Masatake Iwasaki <iwasak...@oss.nttdata.co.jp>
Subject Re: HTrace 3.2 - Can't build HTrace-HTraced package
Date Tue, 20 Dec 2016 15:08:43 GMT
Hi Mihir,

>     [exec] godep: open Godeps/Godeps.json: no such file or directory
>     [exec] failed to set up dependencies

Did you try to build htrace-htraced on OS X?
looks like HTRACE-255: https://issues.apache.org/jira/browse/HTRACE-255

Since the fix version of HTRACE-255 is 4.0.1,
you need equivalent fix on 3.2 if that's the case.

Thanks,
Masatake Iwasaki

On 12/16/16 14:26, Mihir Monani wrote:
> Hi,
>
> I have installed all the dependency required for HTrace.
>
> I am able to build 4.1.0 without any problems.
>
> Here is what i did :-
>
> *git clone https://github.com/apache/incubator-htrace.git
> <https://github.com/apache/incubator-htrace.git>*
> *git checkout 3.2*
> *mvn clean install -DskipTests -Dmaven.javadoc.skip=true*
>
>   I am not able to build 3.2 branch from git.
>
> Errors which i face :-
> [INFO]
>
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Building htrace-htraced 3.2.0-incubating
> [INFO]
> ------------------------------------------------------------------------
>
> ### dowanloads some dependencies ###
>
> [INFO]
> [INFO] --- maven-resources-plugin:2.6:resources (default-resources) @
> htrace-htraced ---
> [INFO] Using 'UTF-8' encoding to copy filtered resources.
> [INFO] skip non existing resourceDirectory
> /home/user/git/incubator-htrace_3.2/htrace-htraced/src/main/resources
> [INFO] Copying 3 resources
> [INFO]
> [INFO] --- maven-compiler-plugin:2.5.1:compile (default-compile) @
> htrace-htraced ---
> [INFO] Compiling 1 source file to
> /home/user/git/incubator-htrace_3.2/htrace-htraced/target/classes
> [INFO]
> [INFO] --- maven-antrun-plugin:1.6:run (go_compile) @ htrace-htraced ---
> [WARNING] Parameter tasks is deprecated, use target instead
> [INFO] Executing tasks
>
> main:
>       [exec] godep restore...
>       [exec] godep: [WARNING]: godep should only be used inside a valid go
> package directory and
>       [exec] godep: [WARNING]: may not function correctly. You are probably
> outside of your $GOPATH.
>       [exec] godep: [WARNING]: Current Directory:
> /home/user/git/incubator-htrace_3.2/htrace-htraced/src/go/build
>       [exec] godep: [WARNING]: $GOPATH:
> /home/user/git/incubator-htrace_3.2/htrace-htraced/src/go/build:/home/user/git/incubator-htrace_3.2/htrace-htraced/src/go
>       [exec] godep: open Godeps/Godeps.json: no such file or directory
>       [exec] failed to set up dependencies
> [INFO]
> ------------------------------------------------------------------------
> [INFO] BUILD FAILURE
> [INFO]
> ------------------------------------------------------------------------
>
>
>
> I am not able to think what is the problem with 3.2 ( or 3.x) version. I
> also face same error with 3.1 too.
>
> Thanks,
> Mihir Monani
>


Mime
View raw message