htrace-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Colin McCabe <cmcc...@apache.org>
Subject Re: Using HTrace 3 & 4 together
Date Mon, 10 Oct 2016 17:19:32 GMT
On Thu, Oct 6, 2016, at 11:06, Mike Drob wrote:
> Devs,
> 
> Is it possible to use HTrace 3 & 4 together to get combined traces?

Unfortunately, it's currently not possible.

> If I'm
> developing an application that will use the latest and greatest from
> HTrace
> 4, but I'm tied to an older version of Hadoop that runs HTrace 3, then
> what
> does this integration need to look like?

It is definitely a problem that the latest Apache version of Hadoop
still uses HTrace 3.x.  We've been waiting for the Hadoop 2.8 release
for a while, to try to resolve this issue.
I wonder if it we could try to backport HTrace 4.x to 2.6 or 2.7?

One thing to keep in mind is that the HTrace 3.x code in Hadoop 2.6 and
earlier was not fully baked-- you have to wait until the 2.8 release to
get that.

> I've been trying to wire them up
> together, but have not had any success so far.

Hmm. This would be a challenge.  A lot of things changed-- the size of
IDs, how libraries were handled, etc.

Cheers,
Colin

> 
> Thanks,
> Mike

Mime
View raw message