hivemind-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Hübner <sthueb...@googlemail.com>
Subject Re: property not wired
Date Tue, 31 Jan 2006 09:04:09 GMT
Hm, I remember some situations where I had similar problems. As far as
I remember there could be an issue in constructing an class instance
not on a service but explicitly on a class, as you do in the provided
example (Connection).

Could you - just to check that - define a connection interface and use
that to construct your connection instance against? Does autowiring
work then?

Stefan

On 31/01/06, John Coleman <john.s.coleman@ntlworld.com> wrote:
> Thanks Stefan, that make sense, why it does not autowire does not. Any ideas
> on that?
>
> John
>
> ----- Original Message -----
> From: "Stefan Hübner" <sthuebner@googlemail.com>
> To: <hivemind-user@jakarta.apache.org>
> Sent: Tuesday, January 31, 2006 8:33 AM
> Subject: Re: property not wired
>
>
> > Hi John,
> >
> > I'd say that your module isn't quite right regarding the
> > construct-statement's syntax. The set-service-tag needs to be inside
> > the construct-statement. Have a look at
> > http://jakarta.apache.org/hivemind/hivemind/BuilderFactory.html for
> > more information on the syntax.
> >
> > Regards,
> > Stefan
> >
> > On 31/01/06, John Coleman <john.s.coleman@ntlworld.com> wrote:
> > >  ...
> > >     <invoke-factory>
> > >       <construct class="Connection"/>
> > >         <set-service property="eventBroker" service-id="Broker"/>
> > >     </invoke-factory>
> > > ...
> >
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: hivemind-user-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: hivemind-user-help@jakarta.apache.org
>
>
Mime
View raw message