hivemind-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Renat Zubairov <renat.zubai...@gmail.com>
Subject HiveTranse and HiveMind classloading assumptions
Date Fri, 23 Sep 2005 09:21:55 GMT
Hello!

I have some problems with loading hibernate configuration using
hivetranse library and I guess it is more HiveMind than HiveTranse
problem.
I have two projects (for simplicity they might be assumed as 2
separate jar files) in one project I have a domain model with
Hibernate mappings and all tests for them (call this project model).
Project "model" is absolute unaware about existing of the HiveMind.
Seond project a "core" that uses domain model from the project "model"
and uses HiveMind and Hibernate mapping and configuration files.
I used to use my own hibernate wrappers, but after digging inside
hivetranse (a beautifyll framework) I've decided to use it instead,
I'm trying to configure hibernate like following:

	<!-- Configuration point to add class mappings and/or properties -->
	<configuration-point	id="HibernateSettings"
							occurs="1..n"
							schema-id="hivetranse.hibernate3.HibernateSettingsSchema"/>
	<contribution configuration-id="HibernateSettings">
		<property name="hibernate.dialect"
value="org.hibernate.dialect.MySQLDialect"/>
		<property name="hibernate.connection.driver_class"
value="com.mysql.jdbc.Driver"/>
	</contribution>


But then I've got "bad configuration" exception because HiveTranse is
trying to lookup hibernate configuration file in the current JAR
(project) but not in another projects available in the classpath.
How could I solve this problem? Thank you in advance.


--
Best regards,
Renat Zubairov

---------------------------------------------------------------------
To unsubscribe, e-mail: hivemind-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: hivemind-user-help@jakarta.apache.org


Mime
View raw message