hivemind-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Shing Hing Man <mat...@yahoo.com>
Subject Re: hivemind doesn't load my hivemodule.xml
Date Sat, 02 Jul 2005 09:30:42 GMT
I think you get the error because 
the line  

> 		<create-instance
> 		
>
class="ar.com.hgdeoro.apn.pruebas.hivemind.UsuarioActualThreadLocalService"
> 			model="threaded" />

 does not work in version 1.0. ( Light weight
initialisation is available in version 1.1, and not in
1.0.)
In version 1.0,  you need to use invoke-factory 
to set a property in a service.

You can check this out at

http://jakarta.apache.org/hivemind/instance-initialization.html

Shing

--- Horacio <horacio222@yahoo.com> wrote:

> Hi! 
> I'm trying to make hivemind 1.0 work, but I can't.
> 
> I'm working from Eclipse 3.1M6 and Hivemind 1.0.
> I've put my hivemodule.xml in WEB-APP, META-INF,
> classes, lib (all at the same time).
> 
> Here is my hivemodule.xml:
> 
> <?xml version="1.0"?>
> <module id="tesis" version="1.0.0">
> 
> 	<!-- tesis.UsuarioActualThreadLocalService -->
> 	<service-point id="UsuarioActualThreadLocalService"
> 	
>
interface="ar.com.hgdeoro.apn.pruebas.hivemind.IUsuarioActualThreadLocalService">
> 		
> 		<create-instance
> 		
>
class="ar.com.hgdeoro.apn.pruebas.hivemind.UsuarioActualThreadLocalService"
> 			model="threaded" />
> 			
> 	</service-point>
> 
> </module>
> 
> 
> 
> 
> I think the hivemind filter is working ok (here are
> the
> tomcat's logs):
> 
> INFO: Filter 'hibernateFilter' configured
> successfully
> 0    [main] INFO 
>
ar.com.hgdeoro.apn.pruebas.hivemind.UsuarioActualThreadLocalFilter
>  - Ejecutando init()...
> 02/07/2005 02:29:54
> org.apache.hivemind.servlet.HiveMindFilter
> initializeRegistry
> INFO: Constructing HiveMind Registry.
> 02/07/2005 02:29:55
> org.apache.hivemind.servlet.HiveMindFilter
> initializeRegistry
> INFO: Constructed RegistryImpl[locale=es_AR] in 797
> milliseconds.
> log4j:WARN No appenders could be found for logger
> (org.apache.commons.beanutils.ConvertUtils).
> log4j:WARN Please initialize the log4j system
> properly.
> 
> 
> 
> But if I do:
> 
>
registry.getService("tesis.UsuarioActualThreadLocalService",
> IUsuarioActualThreadLocalService.class);
> 
> I get:
> 
> org.apache.hivemind.ApplicationRuntimeException:
> Service point tesis.UsuarioActualThreadLocalService
> does not exist.
> 
> 
> What could be the problem??? I've trying to make it
> work since days, but I can't!!
> 
> Thanks in advance.
> Horacio
> 
> 
> 		
> __________________________________ 
> Yahoo! Mail Mobile 
> Take Yahoo! Mail with you! Check email on your
> mobile phone. 
> http://mobile.yahoo.com/learn/mail 
> 
>
---------------------------------------------------------------------
> To unsubscribe, e-mail:
> hivemind-user-unsubscribe@jakarta.apache.org
> For additional commands, e-mail:
> hivemind-user-help@jakarta.apache.org
> 
> 


Home page :
  http://uk.geocities.com/matmsh/index.html


		
___________________________________________________________ 
How much free photo storage do you get? Store your holiday 
snaps for FREE with Yahoo! Photos http://uk.photos.yahoo.com

---------------------------------------------------------------------
To unsubscribe, e-mail: hivemind-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: hivemind-user-help@jakarta.apache.org


Mime
View raw message