hivemind-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Renat Zubairov <renat.zubai...@gmail.com>
Subject Re: Strange problems with HiveMind in WEB app
Date Tue, 19 Apr 2005 13:44:39 GMT
Thank you for answer, but I'm not deleting my app, but trying to undeploy it 
using tomcat manager, and this behaviour doesn't showing up when HiveMInd 
libraries are not used. That's definit sign of the memory leaks somewhere?

On 19/04/05, Charles Harvey III <charlieh@alloy.com> wrote:
> 
> Check your <tomcat>/conf/Catalina/localhost/ directory. Each webapp
> gets its own APPNAME.xml file that Tomcat creates. If you delete
> your app from /webapps/ it stays there. And if the <tomcat>/work/
> directory is not cleared out, the app may still linger.
> 
> Charlie
> 
> Renat Zubairov said the following on 4/19/2005 5:57 AM:
> 
> > Hello,
> >
> > I'm using HiveMind in my webapp delployed under Tomcat 5.5.7 (JRE
> > 1.5.0_01-b08). I'm using HiveMind Filter for initialization registry.
> > Problem is when I undeploy my application, everything in the
> > webapp/<APPNAME> should be deleted, but it doesn't happened, HiveMind
> > libraries
> > are still there and that causes allot of problems.
> > I think it something to do with memory management, i.e. HiveMInd
> > stored a references on its libraries in the wrong ClassLoader
> > Had anybody run into the same problems?
> >
> > --
> > Best regards,
> > Renat Zubairov
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: hivemind-user-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: hivemind-user-help@jakarta.apache.org
> 
> 


-- 
Best regards,
Renat Zubairov

Mime
View raw message