hivemind-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hal Hildebrand" <hal.hildebr...@hellblazer.com>
Subject RE: Problem building HiveMind registry in JBoss
Date Thu, 24 Mar 2005 14:32:56 GMT
I believe this is the same as 

http://issues.apache.org/jira/browse/HIVEMIND-81 

> -----Original Message-----
> From: Markus Wiederkehr [mailto:markus.wiederkehr@gmail.com]
> Sent: Thursday, March 24, 2005 6:03 AM
> To: Hivemind development
> Subject: Problem building HiveMind registry in JBoss
> 
> I have a problem when I try to deploy a HiveMind application in JBoss
> 3.2.7 under Windows. Here is the log output:
> 
> 2005-03-24 14:46:46,250 DEBUG
> [org.apache.hivemind.impl.RegistryBuilder] Processing modules visible
> to org.apache.hivemind.impl.DefaultClassResolver@101e081
> 2005-03-24 14:46:46,359 DEBUG
> [org.apache.hivemind.parse.DescriptorParser] Parsing
> file:/C:/Dokumente und
> Einstellungen/Markus/Desktop/jboss-
> 3.2.7/server/default/tmp/deploy/tmp63889TrustedDigitalRepositoryApp.ear-
> contents/TrustedDigitalRepositoryWeb.war/META-INF/hivemodule.xml
> 2005-03-24 14:46:46,453 ERROR
> [org.apache.hivemind.impl.RegistryBuilder] Error: null
> java.lang.NullPointerException
>         at
> org.apache.hivemind.parse.AbstractParser.getLocation(AbstractParser.java:1
> 58)
>         at
> org.apache.hivemind.parse.DescriptorParser.parse(DescriptorParser.java:142
> 0)
>         at
> org.apache.hivemind.impl.RegistryBuilder.processModule(RegistryBuilder.jav
> a:216)
>         at
> org.apache.hivemind.impl.RegistryBuilder.processModulesResources(RegistryB
> uilder.java:199)
>         at
> org.apache.hivemind.impl.RegistryBuilder.processModules(RegistryBuilder.ja
> va:172)
>         at
> org.apache.hivemind.servlet.HiveMindFilter.constructRegistry(HiveMindFilte
> r.java:111)
>         at
> org.apache.hivemind.servlet.HiveMindFilter.initializeRegistry(HiveMindFilt
> er.java:87)
>         at
> org.apache.hivemind.servlet.HiveMindFilter.init(HiveMindFilter.java:75)
> 
> The problem disappears when I move the JBoss installation directory
> from "C:\Dokumente und Einstellungen\Markus\Desktop" to "C:\".
> 
> Is it possible that space characters in the filename are causing the
> problem?
> 
> Markus
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: hivemind-dev-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: hivemind-dev-help@jakarta.apache.org



---------------------------------------------------------------------
To unsubscribe, e-mail: hivemind-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: hivemind-dev-help@jakarta.apache.org


Mime
View raw message