hive-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From sanjeev <vanj...@yahoo.co.in>
Subject Metastore Schema Upgrade : 'ALTER TABLE' cannot be performed on 'COMPACTION_QUEUE' because it does not exist
Date Sat, 07 Jan 2017 16:12:42 GMT

Hi

I am trying to upgrade metastore schema from 1.2.0 to 2.1.1 using the schematool by command:
schematool -dbType derby -upgradeSchemaFrom 1.2.0

Getting an error:

SLF4J: Actual binding is of type [org.apache.logging.slf4j.Log4jLoggerFactory]
Metastore connection URL:        jdbc:derby:;databaseName=metastore_db;create=true
Metastore Connection Driver :    org.apache.derby.jdbc.EmbeddedDriver
Metastore connection User:       APP
Starting upgrade metastore schema from version 1.2.0 to 2.1.0
Upgrade script upgrade-1.2.0-to-2.0.0.derby.sql
Error: 'ALTER TABLE' cannot be performed on 'COMPACTION_QUEUE' because it does not exist.
(state=42Y55,code=30000)
org.apache.hadoop.hive.metastore.HiveMetaException: Upgrade FAILED! Metastore state would
be inconsistent !!
Underlying cause: java.io.IOException : Schema script failed, errorcode 2
Use --verbose for detailed stacktrace.

Is it advisable to comment out the specific 'ALTER TABLE' in the script and retry ?
If not, can you help with the way forward.

Regards
Sanjeev V
Mime
View raw message