hive-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jose Rozanec <jose.roza...@mercadolibre.com>
Subject Upgrading Metastore schema 2.0.0->2.1.0
Date Wed, 29 Jun 2016 13:46:30 GMT
Hi all,

Upgrading DB schema from 2.0.0 to 2.1.0 is causing an error. Did anyone
experience similar issues?

Below we leave the command and stacktrace.

Thanks,

*./schematool -dbType mysql -upgradeSchemaFrom 2.0.0*
Starting upgrade metastore schema from version 2.0.0 to 2.1.0
Upgrade script upgrade-2.0.0-to-2.1.0.mysql.sql
Error: Duplicate key name 'CONSTRAINTS_PARENT_TABLE_ID_INDEX'
Query is : CREATE INDEX `CONSTRAINTS_PARENT_TABLE_ID_INDEX` ON
KEY_CONSTRAINTS (`PARENT_TBL_ID`) USING BTREE (state=42000,code=1061)
org.apache.hadoop.hive.metastore.HiveMetaException: Upgrade FAILED!
Metastore state would be inconsistent !!
Underlying cause: java.io.IOException : Schema script failed, errorcode 2
Use --verbose for detailed stacktrace.
*** schemaTool failed ***

Mime
View raw message