hive-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Thomas Achache <t.acha...@criteo.com>
Subject RE: HIVE CLI does not escape \t ?
Date Thu, 21 Jan 2016 11:23:34 GMT
Thanks Gopal

I tried that but it generates as many files as mappers (no reducers in this query). 
Tried: 
- set hive.exec.max.created.files=1; does not work, execution stops after more than 1 file
is created
- set mapred.map.tasks=1; does not work either, still using 35 mappers

I use the workaround cat * >> output.tsv but that's not ideal. 

Any way to constrain the number of files to 1 automatically?

 
-----Message d'origine-----
De : Gopal Vijayaraghavan [mailto:gopal@hortonworks.com] De la part de Gopal Vijayaraghavan
Envoyé : jeudi 21 janvier 2016 01:31
À : user@hive.apache.org
Cc : Thomas Achache <t.achache@criteo.com>
Objet : Re: HIVE CLI does not escape \t ?

> I¹m exporting a table with Hive CLI using hive ­f query.hql > file.tsv 
> Use ^A as a separator
 
...
> Maybe using an alternative SerDe could solve that?
 

Have you tried using the actual SerDe instead of the stdout formatter?

INSERT OVERWRITE LOCAL DIRECTORY '...' <select>;

The only issue I've noticed there is with mixed windows new lines being unescaped.

Cheers,
Gopal




Mime
View raw message