hive-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jone Zhang <joyoungzh...@gmail.com>
Subject Re: Hive version with Spark
Date Fri, 20 Nov 2015 01:39:25 GMT
*-Phive is e**nough*
*-Phive will use hive1.2.1 default on Spark1.5.0+*

2015-11-19 4:50 GMT+08:00 Udit Mehta <umehta@groupon.com>:

> As per this link :
> https://cwiki.apache.org/confluence/display/Hive/Hive+on+Spark%3A+Getting+Started,
> you need to build Spark without Hive.
>
> On Wed, Nov 18, 2015 at 8:50 AM, Sofia <sofia.panagiotidi@taiger.com>
> wrote:
>
>> Hello
>>
>> After various failed tries to use my Hive (1.2.1) with my Spark (Spark
>> 1.4.1 built for Hadoop 2.2.0) I decided to try to build again Spark with
>> Hive.
>> I would like to know what is the latest Hive version that can be used to
>> build Spark at this point.
>>
>> When downloading Spark 1.5 source and trying:
>>
>> *mvn -Pyarn -Phadoop-2.6 -Dhadoop.version=2.6.0 -Phive -Phive-1.2.1
>> -Phive-thriftserver  -DskipTests clean package*
>>
>> I get :
>>
>> *The requested profile "hive-1.2.1" could not be activated because it
>> does not exist.*
>>
>> Thank you
>> Sofia
>>
>
>

Mime
View raw message