hive-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jörn Franke <jornfra...@gmail.com>
Subject Re: hive metastore update from 0.12 to 1.0
Date Wed, 04 Nov 2015 07:39:45 GMT
Probably you started the new Hive version before upgrading the schema. This means manual fixing.


> On 03 Nov 2015, at 11:56, Sanjeev Verma <sanjeev.verma82@gmail.com> wrote:
> 
> Hi 
> 
> I am trying to update the metastore using schematool but getting error 
> 
> schematool -dbType derby -upgradeSchemaFrom 0.12 
> 
> Upgrade script upgrade-0.12.0-to-0.13.0.derby.sql 
> Error: Table/View 'TXNS' already exists in Schema 'APP'. (state=X0Y32,code=30000) 
> org.apache.hadoop.hive.metastore.HiveMetaException: Upgrade FAILED! Metastore state would
be inconsistent !!
> 
> could you let me know whats going wrong here
> 
> Thanks

Mime
View raw message