hive-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mich Talebzadeh" <m...@peridale.co.uk>
Subject RE: Problem with Hive metastore
Date Thu, 15 Oct 2015 20:52:01 GMT
What type of metastore are you using?

 

 

Mich Talebzadeh

 

Sybase ASE 15 Gold Medal Award 2008

A Winning Strategy: Running the most Critical Financial Data on ASE 15

http://login.sybase.com/files/Product_Overviews/ASE-Winning-Strategy-091908.pdf

Author of the books "A Practitioner’s Guide to Upgrading to Sybase ASE 15", ISBN 978-0-9563693-0-7.


co-author "Sybase Transact SQL Guidelines Best Practices", ISBN 978-0-9759693-0-4

Publications due shortly:

Complex Event Processing in Heterogeneous Environments, ISBN: 978-0-9563693-3-8

Oracle and Sybase, Concepts and Contrasts, ISBN: 978-0-9563693-1-4, volume one out shortly

 

http://talebzadehmich.wordpress.com <http://talebzadehmich.wordpress.com/> 

 

NOTE: The information in this email is proprietary and confidential. This message is for the
designated recipient only, if you are not the intended recipient, you should destroy it immediately.
Any information in this message shall not be understood as given or endorsed by Peridale Technology
Ltd, its subsidiaries or their employees, unless expressly so stated. It is the responsibility
of the recipient to ensure that this email is virus free, therefore neither Peridale Ltd,
its subsidiaries nor their employees accept any responsibility.

 

From: Gary Clark [mailto:gclark@neces.com] 
Sent: 15 October 2015 21:39
To: user@hive.apache.org
Subject: RE: Problem with Hive metastore

 

Thanks yes I did that and the blighter was still failing. I am going to dig around if I see
anything I will let you know.

 

From: Mich Talebzadeh [mailto:mich@peridale.co.uk] 
Sent: Thursday, October 15, 2015 3:37 PM
To: user@hive.apache.org <mailto:user@hive.apache.org> 
Subject: RE: Problem with Hive metastore

 

Hi Gary,

 

 

Do the following at OS level

 

/bin/netstat -alnp|egrep 'Local|9083'

 

Do you see  any connection. If so then it is already running like below:

 

netstat -alnp|egrep 'Local|9083'

 

Proto Recv-Q Send-Q Local Address               Foreign Address             State       PID/Program
name

tcp        0      0 0.0.0.0:9083                0.0.0.0:*                   LISTEN      20598/java

tcp        0      0 127.0.0.1:21693             127.0.0.1:9083              ESTABLISHED 20800/java

tcp        0      0 127.0.0.1:9083              127.0.0.1:21693             ESTABLISHED 20598/java

 

If you see it is running just do

 

kill -9 20598

 

To get rid of it and start it again.

 

HTH

 

Mich Talebzadeh

 

Sybase ASE 15 Gold Medal Award 2008

A Winning Strategy: Running the most Critical Financial Data on ASE 15

http://login.sybase.com/files/Product_Overviews/ASE-Winning-Strategy-091908.pdf

Author of the books "A Practitioner’s Guide to Upgrading to Sybase ASE 15", ISBN 978-0-9563693-0-7.


co-author "Sybase Transact SQL Guidelines Best Practices", ISBN 978-0-9759693-0-4

Publications due shortly:

Complex Event Processing in Heterogeneous Environments, ISBN: 978-0-9563693-3-8

Oracle and Sybase, Concepts and Contrasts, ISBN: 978-0-9563693-1-4, volume one out shortly

 

http://talebzadehmich.wordpress.com <http://talebzadehmich.wordpress.com/> 

 

NOTE: The information in this email is proprietary and confidential. This message is for the
designated recipient only, if you are not the intended recipient, you should destroy it immediately.
Any information in this message shall not be understood as given or endorsed by Peridale Technology
Ltd, its subsidiaries or their employees, unless expressly so stated. It is the responsibility
of the recipient to ensure that this email is virus free, therefore neither Peridale Ltd,
its subsidiaries nor their employees accept any responsibility.

 

From: Gary Clark [mailto:gclark@neces.com] 
Sent: 15 October 2015 16:16
To: user@hive.apache.org <mailto:user@hive.apache.org> 
Subject: Problem with Hive metastore

 

Hello,

 

I hit a problem this morning:

 

./hive –service metastore

 

Caused by: MetaException(message:Could not connect to meta store using any of the URIs provided.
Most recent failure: org.apache.thrift.transport.TTransportException: java.net.ConnectException:
Connection refused

 

I did not see any 9083 ports taken when running the command? Any ideas on how to clean this
up would be appreciated.

 

Cheers,

Gary C


Mime
View raw message