hive-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jerrick Hoang <jerrickho...@gmail.com>
Subject Re: Local hivemetastore service
Date Fri, 04 Sep 2015 06:02:58 GMT
Turns out I just had my hive-site configured incorrectly, nvm :p

On Thu, Sep 3, 2015 at 10:12 PM, Jerrick Hoang <jerrickhoang@gmail.com>
wrote:

> Hi all,
>
>
> So I have a machine that has hive installed, the actual hivemetastore
> rdbms is installed in a remote machine. I started hive metastore service
> locally at port 10001. But when I'm trying to connect to this service, I
> keep getting,
>
> ```2015-09-03T22:10:01.671-0700 INFO main hive.metastore Trying to
> connect to metastore with URI thrift://0.0.0.0:10001
> 2015-09-03T22:10:01.700-0700 WARN main hive.metastore Failed to connect
> to the MetaStore Server...
> 2015-09-03T22:10:01.700-0700 INFO main hive.metastore Waiting 1 seconds
> before next connection attempt.
> 2015-09-03T22:10:02.704-0700 INFO main hive.metastore Trying to connect
> to metastore with URI thrift://0.0.0.0:10001
> 2015-09-03T22:10:02.704-0700 WARN main hive.metastore Failed to connect
> to the MetaStore Server...
> 2015-09-03T22:10:02.704-0700 INFO main hive.metastore Waiting 1 seconds
> before next connection attempt.
> 2015-09-03T22:10:03.708-0700 INFO main hive.metastore Trying to connect
> to metastore with URI thrift://0.0.0.0:10001
> 2015-09-03T22:10:03.709-0700 WARN main hive.metastore Failed to connect
> to the MetaStore Server...
> 2015-09-03T22:10:03.709-0700 INFO main hive.metastore Waiting 1 seconds
> before next connection attempt.
> 2015-09-03T22:10:04.758-0700 INFO main hive.metastore Trying to connect
> to metastore with URI thrift://0.0.0.0:10001
> 2015-09-03T22:10:04.758-0700 WARN main hive.metastore Failed to connect
> to the MetaStore Server...
> 2015-09-03T22:10:04.758-0700 INFO main hive.metastore Waiting 1 seconds
> before next connection attempt.
> 2015-09-03T22:10:05.762-0700 INFO main hive.metastore Trying to connect
> to metastore with URI thrift://0.0.0.0:10001
> 2015-09-03T22:10:05.763-0700 WARN main hive.metastore Failed to connect
> to the MetaStore Server...
> 2015-09-03T22:10:05.763-0700 INFO main hive.metastore Waiting 1 seconds
> before next connection attempt.
> 2015-09-03T22:10:06.766-0700 INFO main hive.metastore Trying to connect
> to metastore with URI thrift://0.0.0.0:10001
> 2015-09-03T22:10:06.767-0700 WARN main hive.metastore Failed to connect
> to the MetaStore Server...
> 2015-09-03T22:10:06.767-0700 INFO main hive.metastore Waiting 1 seconds
> before next connection attempt.```
>
> and it finally failed.
>
> I connect to it by using
>
> ```HiveConf conf = new HiveConf()
> conf.setVar(HiveConf.ConfVars.METASTOREURIS, "thrift://127.0.0.1:10001")
> new HiveMetastoreClient(conf)```
>
> Am I setting the right flag?
> Thanks,
> J
>

Mime
View raw message