hive-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Paulo Moniz <pmon...@hotmail.com>
Subject Starting Hive Thrift Server
Date Wed, 09 Sep 2015 12:13:56 GMT
Hi, I am beginner and may possibly even find my naive questions regarding when trying to connect
to the server hive.
So I ask you to help.
 
After I run the command: ~ $ $ HIVE_HOME / bin / hive --service hiveserver and appear the
messages as shown above, should appear a message indicating that connection hiveserver is
ok?

How do I know if the connection is ok, when the last line is as follows:
SLF4J: Actual binding is of type [org.slf4j.impl.Log4jLoggerFactory]

 
 I am using Apache Hadoop 2.2.0 and Hadoop HIVE 0.12.0 in Ubuntu 14.04 
 
I run the command ($ HIVE_HOME / bin / hive --service hiveserver) it shows the following message
below:


hduser@master-VirtualBox:~$ $HIVE_HOME/bin/hive --service hiveserverStarting Hive Thrift Server15/09/08
09:32:38 INFO Configuration.deprecation: mapred.input.dir.recursive is deprecated. Instead,
use mapreduce.input.fileinputformat.input.dir.recursive15/09/08 09:32:38 INFO Configuration.deprecation:
mapred.max.split.size is deprecated. Instead, use mapreduce.input.fileinputformat.split.maxsize15/09/08
09:32:38 INFO Configuration.deprecation: mapred.min.split.size is deprecated. Instead, use
mapreduce.input.fileinputformat.split.minsize15/09/08 09:32:38 INFO Configuration.deprecation:
mapred.min.split.size.per.rack is deprecated. Instead, use mapreduce.input.fileinputformat.split.minsize.per.rack15/09/08
09:32:38 INFO Configuration.deprecation: mapred.min.split.size.per.node is deprecated. Instead,
use mapreduce.input.fileinputformat.split.minsize.per.node15/09/08 09:32:38 INFO Configuration.deprecation:
mapred.reduce.tasks is deprecated. Instead, use mapreduce.job.reduces15/09/08 09:32:38 INFO
Configuration.deprecation: mapred.reduce.tasks.speculative.execution is deprecated. Instead,
use mapreduce.reduce.speculativeSLF4J: Class path contains multiple SLF4J bindings.SLF4J:
Found binding in [jar:file:/usr/local/hadoop/share/hadoop/common/lib/slf4j-log4j12-1.7.5.jar!/org/slf4j/impl/StaticLoggerBinder.class]SLF4J:
Found binding in [jar:file:/usr/local/hive/hive-0.12.0/lib/slf4j-log4j12-1.6.1.jar!/org/slf4j/impl/StaticLoggerBinder.class]SLF4J:
See http://www.slf4j.org/codes.html#multiple_bindings for an explanation.SLF4J: Actual binding
is of type [org.slf4j.impl.Log4jLoggerFactory] 
Immensely like to get help from you, because I've done numerous and can not move forward because
I believe that is missing something to connect to the server.


I thank you.

Paul Moniz.  		 	   		  
Mime
View raw message