hive-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mich Talebzadeh" <m...@peridale.co.uk>
Subject RE: Error when connecting Hue to HiveServer2
Date Fri, 17 Apr 2015 19:02:38 GMT
It always surprises how many parameters are around for different metastores J

 

 

I use Oracle as my Metastore the parameter is set to

 

  <property>

    <name>hive.server2.authentication</name>

    <value>NONE</value>

    <description>

      Expects one of [nosasl, none, ldap, kerberos, pam, custom].

      Client authentication types.

        NONE: no authentication check

        LDAP: LDAP/AD based authentication

        KERBEROS: Kerberos/GSSAPI authentication

        CUSTOM: Custom authentication provider

                (Use with property hive.server2.custom.authentication.class)

        PAM: Pluggable authentication module

        NOSASL:  Raw transport

    </description>

  </property>

 

Mich Talebzadeh

 

http://talebzadehmich.wordpress.com

 

Author of the books "A Practitioner’s Guide to Upgrading to Sybase ASE 15", ISBN 978-0-9563693-0-7.


co-author "Sybase Transact SQL Guidelines Best Practices", ISBN 978-0-9759693-0-4

Publications due shortly:

Creating in-memory Data Grid for Trading Systems with Oracle TimesTen and Coherence Cache

Oracle and Sybase, Concepts and Contrasts, ISBN: 978-0-9563693-1-4, volume one out shortly

 

NOTE: The information in this email is proprietary and confidential. This message is for the
designated recipient only, if you are not the intended recipient, you should destroy it immediately.
Any information in this message shall not be understood as given or endorsed by Peridale Ltd,
its subsidiaries or their employees, unless expressly so stated. It is the responsibility
of the recipient to ensure that this email is virus free, therefore neither Peridale Ltd,
its subsidiaries nor their employees accept any responsibility.

 

From: Gary Clark [mailto:gclark@neces.com] 
Sent: 17 April 2015 19:56
To: user@hive.apache.org
Subject: RE: Error when connecting Hue to HiveServer2

 

The below I had to set to avoid on a derby database to get past this problem.

 

  <property>

    <name>hive.server2.authentication</name>

    <value>NOSASL</value>

    <description>

      Expects one of [nosasl, none, ldap, kerberos, pam, custom].

      Client authentication types.

        NONE: no authentication check

        LDAP: LDAP/AD based authentication

        KERBEROS: Kerberos/GSSAPI authentication

        CUSTOM: Custom authentication provider

                (Use with property hive.server2.custom.authentication.class)

        PAM: Pluggable authentication module

        NOSASL:  Raw transport

    </description>

  </property>

 

Was None before.

Thanks,

Gary 

 

From: Gary Clark [mailto:gclark@neces.com] 
Sent: Friday, April 17, 2015 1:33 PM
To: user@hive.apache.org
Subject: RE: Error when connecting Hue to HiveServer2

 

2015-04-17 08:24:12,858 DEBUG [HiveServer2-Handler-Pool: Thread-23]: transport.TSaslTransport
(TSaslTransport.java:open(243)) - opening transport org.apache.hadoop.hive.thrift.HadoopThriftAuthBridge$HiveSaslServerTransportFactory$1@12d391f8

2015-04-17 08:24:12,858 DEBUG [HiveServer2-Handler-Pool: Thread-21]: transport.TSaslServerTransport
(HadoopThriftAuthBridge.java:getTransport(179)) - failed to open server transport

org.apache.thrift.transport.TTransportException

 

Its looks like the opening does occur to the thrift server? However failed to open server
Transport? Permission issue ? I opened up all the ports.

 

Chain INPUT (policy ACCEPT)

target     prot opt source               destination         

 

Chain FORWARD (policy ACCEPT)

target     prot opt source               destination         

 

Chain OUTPUT (policy ACCEPT)

target     prot opt source               destination     

 

[root@localhost sbin]# netstat -alnp|egrep 'Local|10000|9083'

Proto Recv-Q Send-Q Local Address               Foreign Address             State       PID/Program
name   

tcp        0      0 0.0.0.0:10000               0.0.0.0:*                   LISTEN      2373/java
          

tcp        0      0 0.0.0.0:9083                0.0.0.0:*                   LISTEN      2265/java
          

tcp        0      0 127.0.0.1:10000             127.0.0.1:48434             CLOSE_WAIT  2373/java
          

tcp        0      0 127.0.0.1:58370             127.0.0.1:9083              ESTABLISHED 2373/java
          

tcp        0      0 127.0.0.1:10000             127.0.0.1:48506             CLOSE_WAIT  2373/java
          

tcp        1      0 127.0.0.1:10000             127.0.0.1:48478             CLOSE_WAIT  2373/java
          

tcp        0      0 127.0.0.1:10000             127.0.0.1:48482             CLOSE_WAIT  2373/java
          

tcp        0      0 127.0.0.1:9083              127.0.0.1:58370             ESTABLISHED 2265/java
          

tcp        0      0 127.0.0.1:10000             127.0.0.1:48508             CLOSE_WAIT  2373/java
          

tcp        0      0 127.0.0.1:10000             127.0.0.1:48510             CLOSE_WAIT  2373/java
          

tcp        0      0 127.0.0.1:10000             127.0.0.1:48436             CLOSE_WAIT  2373/java
          

tcp        0      0 127.0.0.1:10000             127.0.0.1:48438             CLOSE_WAIT  2373/java
          

tcp        0      0 127.0.0.1:10000             127.0.0.1:48480             CLOSE_WAIT  2373/java
          

Ip addresses:

 

Thanks,

Gary C

 

 

From: Gary Clark [mailto:gclark@neces.com] 
Sent: Friday, April 17, 2015 12:57 PM
To: user@hive.apache.org
Subject: RE: Error when connecting Hue to HiveServer2

 

Thanks Mich good test.

 

[root@localhost root]# telnet 127.0.0.1 10000

Trying 127.0.0.1...

Connected to 127.0.0.1.

Escape character is '^]'.

 

Yes all good it seems.

 

Cheers,

Gazza

 

From: Mich Talebzadeh [mailto:mich@peridale.co.uk] 
Sent: Friday, April 17, 2015 11:44 AM
To: user@hive.apache.org
Subject: RE: Error when connecting Hue to HiveServer2

 

OK so both are running and up (metastore on 9083 and hiveserver on 10000

 

Try doing

 

telnet hostname 10000

 

Can you connect like below (mine runs on 10010 J)

 

hduser@rhes564::/home/hduser> telnet rhes564 10010

Trying 50.140.197.217...

Connected to rhes564.

Escape character is '^]'.

 

 

Mich Talebzadeh

 

http://talebzadehmich.wordpress.com

 

Author of the books "A Practitioner’s Guide to Upgrading to Sybase ASE 15", ISBN 978-0-9563693-0-7.


co-author "Sybase Transact SQL Guidelines Best Practices", ISBN 978-0-9759693-0-4

Publications due shortly:

Creating in-memory Data Grid for Trading Systems with Oracle TimesTen and Coherence Cache

Oracle and Sybase, Concepts and Contrasts, ISBN: 978-0-9563693-1-4, volume one out shortly

 

NOTE: The information in this email is proprietary and confidential. This message is for the
designated recipient only, if you are not the intended recipient, you should destroy it immediately.
Any information in this message shall not be understood as given or endorsed by Peridale Ltd,
its subsidiaries or their employees, unless expressly so stated. It is the responsibility
of the recipient to ensure that this email is virus free, therefore neither Peridale Ltd,
its subsidiaries nor their employees accept any responsibility.

 

From: Gary Clark [mailto:gclark@neces.com] 
Sent: 17 April 2015 17:39
To: user@hive.apache.org
Subject: RE: Error when connecting Hue to HiveServer2

 

Hi Mich,

 

tcp        0      0 0.0.0.0:10000               0.0.0.0:*                   LISTEN      16561/java
         

tcp        0      0 0.0.0.0:9083                0.0.0.0:*                   LISTEN      16654/java
         

 

I am starting to think this is firewall issue not sure what is going on.

 

Yep HiveServer2 is running.

 

Cheers,

Gazza

 

From: Mich Talebzadeh [mailto:mich@peridale.co.uk] 
Sent: Friday, April 17, 2015 11:36 AM
To: user@hive.apache.org
Subject: RE: Error when connecting Hue to HiveServer2

 

Hi Gary,

 

Is your hiverserver2 running OK. How did you start it?

 

$HIVE_HOME/bin/hiveserver2 &

 

 

What do you when you run the command below? I assume that your hiveserver is running on port
10000?

 

netstat -alnp|egrep 'Local|10000|9083'

 

 

HTH

 

Mich Talebzadeh

 

http://talebzadehmich.wordpress.com

 

Author of the books "A Practitioner’s Guide to Upgrading to Sybase ASE 15", ISBN 978-0-9563693-0-7.


co-author "Sybase Transact SQL Guidelines Best Practices", ISBN 978-0-9759693-0-4

Publications due shortly:

Creating in-memory Data Grid for Trading Systems with Oracle TimesTen and Coherence Cache

Oracle and Sybase, Concepts and Contrasts, ISBN: 978-0-9563693-1-4, volume one out shortly

 

NOTE: The information in this email is proprietary and confidential. This message is for the
designated recipient only, if you are not the intended recipient, you should destroy it immediately.
Any information in this message shall not be understood as given or endorsed by Peridale Ltd,
its subsidiaries or their employees, unless expressly so stated. It is the responsibility
of the recipient to ensure that this email is virus free, therefore neither Peridale Ltd,
its subsidiaries nor their employees accept any responsibility.

 

From: Gary Clark [mailto:gclark@neces.com] 
Sent: 17 April 2015 17:27
To: user@hive.apache.org
Subject: Error when connecting Hue to HiveServer2

 

Hey Guys,

 

I am see the following error when attempting to connect Hue to the hive metatstore:

 

>From hive-site.log

 

015-04-17 05:12:48,857 INFO  [main]: metastore.HiveMetaStore (HiveMetaStore.java:addAdminUsers_core(679))
- No user is added in admin role, since config is empty

2015-04-17 05:12:48,971 INFO  [main]: metastore.HiveMetaStore (HiveMetaStore.java:startMetaStore(5740))
- Starting DB backed MetaStore Server with SetUGI enabled

2015-04-17 05:12:48,973 INFO  [main]: metastore.HiveMetaStore (HiveMetaStore.java:startMetaStore(5757))
- Started the new metaserver on port [9083]...

2015-04-17 05:12:48,973 INFO  [main]: metastore.HiveMetaStore (HiveMetaStore.java:startMetaStore(5759))
- Options.minWorkerThreads = 200

2015-04-17 05:12:48,973 INFO  [main]: metastore.HiveMetaStore (HiveMetaStore.java:startMetaStore(5761))
- Options.maxWorkerThreads = 100000

2015-04-17 05:12:48,973 INFO  [main]: metastore.HiveMetaStore (HiveMetaStore.java:startMetaStore(5763))
- TCP keepalive = true

2015-04-17 05:12:50,863 DEBUG [HiveServer2-Handler-Pool: Thread-23]: transport.TSaslServerTransport
(HadoopThriftAuthBridge.java:getTransport(174)) - transport map does not contain key org.apache.thrift.transport.TSocket@2f0c37a9

2015-04-17 05:12:50,863 DEBUG [HiveServer2-Handler-Pool: Thread-22]: transport.TSaslServerTransport
(HadoopThriftAuthBridge.java:getTransport(174)) - transport map does not contain key org.apache.thrift.transport.TSocket@2c92f525

2015-04-17 05:12:50,863 DEBUG [HiveServer2-Handler-Pool: Thread-21]: transport.TSaslServerTransport
(HadoopThriftAuthBridge.java:getTransport(174)) - transport map does not contain key org.apache.thrift.transport.TSocket@4b1a5060

2015-04-17 05:12:50,866 DEBUG [HiveServer2-Handler-Pool: Thread-22]: transport.TSaslTransport
(TSaslTransport.java:open(243)) - opening transport org.apache.hadoop.hive.thrift.HadoopThriftAuthBridge$HiveSaslServerTransportFactory$1@4aa5331

2015-04-17 05:12:50,866 DEBUG [HiveServer2-Handler-Pool: Thread-21]: transport.TSaslTransport
(TSaslTransport.java:open(243)) - opening transport org.apache.hadoop.hive.thrift.HadoopThriftAuthBridge$HiveSaslServerTransportFactory$1@4a3bb85b

2015-04-17 05:12:50,866 DEBUG [HiveServer2-Handler-Pool: Thread-23]: transport.TSaslTransport
(TSaslTransport.java:open(243)) - opening transport org.apache.hadoop.hive.thrift.HadoopThriftAuthBridge$HiveSaslServerTransportFactory$1@16c48470

2015-04-17 05:12:50,866 DEBUG [HiveServer2-Handler-Pool: Thread-22]: transport.TSaslServerTransport
(HadoopThriftAuthBridge.java:getTransport(179)) - failed to open server transport

org.apache.thrift.transport.TTransportException

        at org.apache.thrift.transport.TIOStreamTransport.read(TIOStreamTransport.java:132)

 

I am using the derby database. Not sure what I am missing?

 

Any ideas would of course helpful.

 

Much Appreciated,

gazza


Mime
View raw message