hive-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Eugene Koifman <ekoif...@hortonworks.com>
Subject Re: Submitting via WebHCat won't put hive log into ATS?
Date Tue, 24 Mar 2015 01:27:01 GMT
I'm working https://issues.apache.org/jira/browse/HIVE-10066 where I plan to make all of hive-site.xml
be available to webhcat's LaunchMapper so that these settings don't have to be duplicated
in templeton.hive.properties.

From: Lefty Leverenz <leftyleverenz@gmail.com<mailto:leftyleverenz@gmail.com>>
Reply-To: "user@hive.apache.org<mailto:user@hive.apache.org>" <user@hive.apache.org<mailto:user@hive.apache.org>>
Date: Monday, March 23, 2015 at 5:37 PM
To: "user@hive.apache.org<mailto:user@hive.apache.org>" <user@hive.apache.org<mailto:user@hive.apache.org>>,
"dev@hive.apache.org<mailto:dev@hive.apache.org>" <dev@hive.apache.org<mailto:dev@hive.apache.org>>
Subject: Re: Submitting via WebHCat won't put hive log into ATS?

Should this be documented in the wiki?  (For example, in the WebHCat Configuration Variables<https://cwiki.apache.org/confluence/display/Hive/WebHCat+Configure#WebHCatConfigure-ConfigurationVariables>
section with a link from Error Logs<https://cwiki.apache.org/confluence/display/Hive/GettingStarted#GettingStarted-ErrorLogs>
in Getting Started.)

-- Lefty

On Mon, Mar 23, 2015 at 8:00 PM, Xiaoyong Zhu <xiaoyzhu@microsoft.com<mailto:xiaoyzhu@microsoft.com>>
wrote:
Confirmed with Zhijie Shen from Hortonworks (big thanks for the help!) and it is actually
caused by the fact that WebHCat does not know Hive configurations.
Assuming you have set the following properties for Hive:
[cid:image001.png@01D06608.A0B59290]
Then putting these three properties into templeton.hive.properties would workaround this issue.

Xiaoyong

From: Xiaoyong Zhu [mailto:xiaoyzhu@microsoft.com<mailto:xiaoyzhu@microsoft.com>]
Sent: Saturday, March 21, 2015 8:15 PM
To: user@hive.apache.org<mailto:user@hive.apache.org>
Subject: Submitting via WebHCat won't put hive log into ATS?

Hi Hive experts,

I know that Hive is writing logs to ATS (application timeline server) when a hive script is
executed from the CLI. However, when I try to submit Hive jobs from WebHCat, it seems that
it does not write logs into ATS? How could I configure Hive to make the jobs submitted from
WebHCat also log into ATS?

Thanks!

Xiaoyong



Mime
View raw message