hive-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From James Teng <tenglinx...@outlook.com>
Subject RE: run hiveserver2 with no authentication mode.
Date Mon, 23 Mar 2015 08:49:18 GMT
thanks, do you know to how config hiveserver2 with ldap service? i have configured but can't
make it connect to server.
i have filed an ticket on the url: http://stackoverflow.com/questions/29206038/hiveserver2-bind-ldap-authenticationCould
you plz take a look?
thanks
ukown.
> From: slavakileev@yandex.ru
> To: user@hive.apache.org
> Subject: Re:run hiveserver2 with no authentication mode.
> Date: Mon, 23 Mar 2015 10:50:23 +0300
> 
> Hello!
> 
> Try to use user root with blank password. It worked for me. So it should work for you
as well.
> 
> > could anyone answer my question?uknow.
> > 
> > From: tenglinxiao@outlook.com
> > To: user@hive.apache.org
> > Subject: run hiveserver2 with no authentication mode.
> > Date: Wed, 18 Mar 2015 13:14:31 +0000
> > 
> > Hi all,
> > 
> > i am pretty new to hive and would like to consult one issue that whether the hiveserver2
can run with no authentication mode. i have tried to configure the hive-site.xml file as below(this
is the only one hiveserver2 related in my config file):
> > <property>
> > <name>hive.server2.authentication</name>
> > <value>none</value>
> > </property>
> > 
> > but i can't connect to server when trying attempts with beeline. and if no username/password
is specified, always there is an prompt asking for them.
> > could anyone give any comment on this? does hive support no authentication mode
for hiveserver2? and whether there is a way to achieve this.
> > 
> > thanks in advance.
> > 
> > uknow.
 		 	   		  
Mime
View raw message