hive-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ritesh Kumar Singh <riteshoneinamill...@gmail.com>
Subject Re: basic, dumb getting started question (single-node)
Date Wed, 12 Nov 2014 22:25:22 GMT
If you have correctly set your HIVE_HOME variable in your .bash_rc file,
What's the output of:

>cat $HIVE_HOME/conf/hive-env.sh

If it doesn't work, run

>cat $HIVE_HOME/conf/hive-env.sh.template

On Thu, Nov 13, 2014 at 2:57 AM, Nicholas Murphy <nick.murphy@oracle.com>
wrote:

> Sorry for the (as per subject) basic, dumb getting started question but:
> I'm trying to just set up Hive on a single node.  Hadoop is set up and
> running happily, but following the directions on the Getting Started guide
> don't actually work (following the directions literally results in it
> complaining about a lack of a hive-site.conf file; putting a dummy one in
> results in, among other things, the HCatalog server not starting...looking
> at logs, it looks like it's encountering configuration parsing problems,
> which suggests I just don't have the configuration files set up
> correctly).  HADOOP_HOME is set, the correct directories are set up in
> HDFS, etc.
>
> Hadoop version 2.5.1, Hive version 0.13.1, Oracle JDK (1.6, I believe),
> Debian 7.7.
>
> I notice the default conf/ directory has a bunch of template files, but
> only that.  Can someone point me to a resource, or to an example of what
> configuration I need, to actually run Hive correctly out of the box on a
> single machine?
>
> Thanks,
> Nick

Mime
View raw message