hive-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Atul Paldhikar (apaldhik)" <>
Subject RE: Can't integrate Elasticsearch with Hive
Date Fri, 28 Nov 2014 06:53:14 GMT
Thanks Muthu for pointing out the issue.

However unfortunately I am back to the same old issue while accessing the external table.
I am getting the following exception again, there wasn’t any change in the environment.

I tried all the cleanup but still no luck :-( Here are the steps I tried

1. Removed the other jar for es-hadoop 2.1.x completely from the server

2. Updated the hive-site.xml as below, but didn't work

  <description>A comma separated list (with no spaces) of the jar files</description>

3. Added the jar file in the hiveconf as below, still the same issue

hive --hiveconf hive.aux.jars.path=/apps/sas/elasticsearch-hadoop-2.0.2/dist/elasticsearch-hadoop-2.0.2.jar

4. Tried adding the jar file in the hive session, still didn't work

add jar /apps/sas/elasticsearch-hadoop-2.0.2/dist/elasticsearch-hadoop-2.0.2.jar;

- Atul


2014-11-26 23:09:22,069 ERROR [main]: exec.DDLTask ( - java.lang.IllegalAccessError:
tried to access class org.elasticsearch.hadoop.hive.HiveUtils from class org.elasticsearch.hadoop.hive.EsSerDe
        at org.elasticsearch.hadoop.hive.EsSerDe.initialize(
        at org.apache.hadoop.hive.metastore.MetaStoreUtils.getDeserializer(
        at org.apache.hadoop.hive.ql.metadata.Table.getDeserializerFromMetaStore(
        at org.apache.hadoop.hive.ql.metadata.Table.getDeserializer(
        at org.apache.hadoop.hive.ql.metadata.Table.getCols(
        at org.apache.hadoop.hive.ql.metadata.Hive.createTable(
        at org.apache.hadoop.hive.ql.exec.DDLTask.createTable(
        at org.apache.hadoop.hive.ql.exec.DDLTask.execute(
        at org.apache.hadoop.hive.ql.exec.Task.executeTask(
        at org.apache.hadoop.hive.ql.exec.TaskRunner.runSequential(
        at org.apache.hadoop.hive.ql.Driver.launchTask(
        at org.apache.hadoop.hive.ql.Driver.execute(
        at org.apache.hadoop.hive.ql.Driver.runInternal(
        at org.apache.hadoop.hive.cli.CliDriver.processLocalCmd(
        at org.apache.hadoop.hive.cli.CliDriver.processCmd(
        at org.apache.hadoop.hive.cli.CliDriver.processLine(
        at org.apache.hadoop.hive.cli.CliDriver.executeDriver(
        at org.apache.hadoop.hive.cli.CliDriver.main(
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(
        at java.lang.reflect.Method.invoke(
        at org.apache.hadoop.util.RunJar.main(

2014-11-26 23:09:22,069 ERROR [main]: ql.Driver ( - FAILED:
Execution Error, return code 1 from org.apache.hadoop.hive.ql.exec.DDLTask. tried to access
class org.elasticsearch.hadoop.hive.HiveUtils from class org.elasticsearch.hadoop.hive.EsSerDe

From: Muthu Pandi []
Sent: Thursday, November 27, 2014 9:08 PM
Subject: Re: Can't integrate Elasticsearch with Hive

Hi Atul

     Check your typo "tblproperties('es.resources' = 'employee/address') " need to be "es.resource"
as it rightly indicated in the Error.


[Image removed by sender.] Think before you print.

On Fri, Nov 28, 2014 at 3:43 AM, Edward Capriolo <<>>
Because the elastic search storage handler is not part of hive you might be able to find more
help asking the author of the storage handler. From the errors you are reporting it likely
does not work and not tested against this version of hive.

View raw message