hive-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Prashant Sharma" <prashant....@gmail.com>
Subject Re: Hive hwi setup windows 8 using cygwin
Date Sun, 07 Sep 2014 07:11:14 GMT
On Wed, 03 Sep 2014 23:05:59 +0530, Prashant Sharma  
<prashant.x90@gmail.com> wrote:

> Dear All,
>
> 	Kindly help with hwi setup, I am using cygwin on windows 8, jdk 1.7,  
> ant 1.9. I have successfully built hive and able to start the hwi war  
> using command "hive --service hwi". It shows  Started  
> SocketConnector@0.0.0.0:9999 in console.
>
> Problem I am facing is when I open the browser and try to access the hwi  
> url (localhost:9999/hwi)
> I get error in console as below and the webpage also displays the stack  
> trace of same error.
>
> Error :-
>
> 2014-09-03 22:48:36,475 ERROR [1231565732@qtp-362433913-0]  
> compiler.Compiler (AntCompiler.java:generateClass(225)) - Javac exception
> Unable to find a javac compiler;
> com.sun.tools.javac.Main is not on the classpath.
> Perhaps JAVA_HOME does not point to the JDK.
> It is currently set to "C:\Program Files\Java\jdk1.7.0_51\jre"
>          at  
> org.apache.tools.ant.taskdefs.compilers.CompilerAdapterFactory.getCompiler(CompilerAdapterFactory.java:129)
>
>
> Have tried all path related issues solutions for ant, yet the problem is  
> there. Have checked ant also, its working fine in cygwin and windows  
> both,I am able to run all the lifecycle tasks from ant.
>
> Please help.
>
> Thanks
> Prashant

Dear All,

	I have solved the above issue, the same was due to tools.jar not getting  
picked up in the classpath when Jetty server is trying to compile the jsp  
files of hwi. The issue seems to be with jetty server during runtime.

Thanks
Prashant

Mime
View raw message