hive-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nishant Kelkar <>
Subject Re: Hive: Select * command not working similar to RDBMS
Date Tue, 16 Sep 2014 16:34:11 GMT
Hey Siva,

Welcome to Hive! :)

I don't know why the issue you pointed out is happening, but I'd strongly
recommend to go with hive-0.13. There's two reasons for that:
1. This could be something that was indeed an issue with hive-0.9.0 and was
fixed by hive-0.13
2. It will become increasingly difficult for people to reproduce your
error, since the vast majority usually moves with the newer versions of

Apart from this, I hope you find an answer to your question!

Best Regards,
Nishant Kelkar

On Mon, Sep 15, 2014 at 11:28 PM, Sivasakthi <> wrote:

> Hi Hive developers,
> I am new to hive. Yesterday i installed apache hive-0.9.0 and start
> executing some basics command and i found one abnormal behavior in select*
> command.  In select statement after * any random characters are allowed in
> hive but in RDBMS its not allowed.  I am not sure its expected behavior or
> bug in hive. Could some please confirm?
> In the below query "abcdef" is random characters.
> In RDBMS(oracle):
> select *abcdef from mytable;
> Output:
> ERROR prepare() failed with: ORA-00923
> <>: FROM keyword not found where
> expected
> In Hive:
> select *abcdef from mytable;
> Output:
> Query worked fine and display all the records of mytable.
> Thanks
> Siva..

View raw message