hive-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Roberto Congiu <roberto.con...@openx.com>
Subject Re: SerDe errors
Date Thu, 14 Aug 2014 16:49:09 GMT
Can you provide the CREATE statement used to create the table and a sample
of the json that's causing the error ?
It sounds like you have a field declared as bigint on the schema, but it's
actually an object.


On Wed, Aug 13, 2014 at 5:05 AM, Charles Robertson <
charles.robertson@gmail.com> wrote:

> Hi all,
>
> I have a Hive table which relies on a JSON SerDe to read the underlying
> files. When I ran the create script I specified the SerDe and it all went
> fine and the data was visible in the views above the table. When I tried to
> query the table directly, though, I received a ClassNotFound error. I
> solved this by putting the SerDe JAR in /usr/lib/hive/lib.
>
> Now, however, when I try to query the data I get:
>
> Failed with exception
> java.io.IOException:org.apache.hadoop.hive.ql.metadata.HiveException:
> java.lang.ClassCastException: org.json.JSONObject cannot be cast to
> [Ljava.lang.Object;
>
> (The serde is the json serde provided by Apache)
>
> Can anyone suggest why it was working before, but no longer is?
>
> Thanks,
> Charles
>



-- 
----------------------------------------------------------
Good judgement comes with experience.
Experience comes with bad judgement.
----------------------------------------------------------
Roberto Congiu - Data Engineer - OpenX
tel: +1 626 466 1141

Mime
View raw message