hive-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nitin Pawar <nitinpawar...@gmail.com>
Subject Re: Can't drop table
Date Wed, 11 Jun 2014 06:33:44 GMT
if you have added a table with a serde definition

then just keep the jar in local filesystem and then in hive console do
add jar <full path to jar>;

this should make your serde available to table and you should be able to
drop the table then.

I just tried above steps and it works for my json based tables.


On Wed, Jun 11, 2014 at 2:24 AM, Keith Wiley <kwiley@keithwiley.com> wrote:

> I tried to create a table that would use a csv serde.  There were various
> problems with it, primarily in that I couldn't figure out how to specify
> the path to the serde (whether I indicate the serde location either locally
> or on HDFS) there were subsequent errors about not finding the serde, even
> though the paths were correct).
>
> So I decided to drop the table since it wasn't working...but the serde
> error that is causing these problems to begin with prevents me from
> dropping the table due to a serde-doesn't-exist error.  Yeah, duh, that's
> the problem in the first place.
>
> This is an acknowledged problem, as indicated here:
> https://issues.apache.org/jira/browse/HIVE-3392
> ...but I don't understand from that page how to get around the problem.
>  There is a lengthy discussion, but it's unclear how to actually drop the
> darn table.  In fact, that page suggests the problem is officially
> classified as "won't be fixed".
>
> Note, this problem also prevents me from renaming the table via "alter".
>
> I don't know what to do at this point.  Any ideas?
>
>
> ________________________________________________________________________________
> Keith Wiley     kwiley@keithwiley.com     keithwiley.com
> music.keithwiley.com
>
> "The easy confidence with which I know another man's religion is folly
> teaches
> me to suspect that my own is also."
>                                            --  Mark Twain
>
> ________________________________________________________________________________
>
>


-- 
Nitin Pawar

Mime
View raw message