hive-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Gayou <>
Subject Re: What is the minimal required version of Hadoop for Hive 0.13.0?
Date Wed, 23 Apr 2014 14:20:34 GMT
I actually have pretty the same issue with Hadoop 1.1.2

There is a jira issue opened here :
with a link to the issue that created our problem.

A quick search in release notes seem's to indicate that the unset method
appeared in the Haddop 1.2.1

Is it now the minimal required version ?
If not, will there be a Hive 0.13.1 for older hadoop?



On Wed, Apr 23, 2014 at 4:00 PM, Dmitry Vasilenko <>wrote:

> Hive 0.12.0 (and previous versions) worked with Hadoop 0.20.x, 0.23.x.y,
> 1.x.y, 2.x.y.
> Hive 0.13.0 did not work with Hadoop 0.20.x out of the box and to make it
> work I had to patch Hadoop installation and add Path(URL) constructor and
> Configuration.unset() method.
> After that the basic functionality seems to be working.
> Both issues originate from the org.apache.hadoop.hive.ql.exec.Utilities
> I know that Hadoop 0.20.x is old but some of us still have to work with
> that version. So does anyone know what is the minimal required version of
> Hadoop for Hive 0.13.0?
> Thanks
> Dmitry Vasilenko

View raw message