hive-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Björn-Elmar Macek <ma...@cs.uni-kassel.de>
Subject Compiling the current source and running hive
Date Thu, 07 Nov 2013 08:44:14 GMT

> 
> Hi,
> 
> i am currently upgrading to the new maven based version of Hive, when recently a library
(kryo … something) was not available as a SNAPSHOT version anymore.
> What i am currently experiencing is the following:
> 
> After checking out the source, i cannot simply compile the trunk with a … 
>   mvn clean package -DskipTests (i did also try „mvn clean install…“)
> … since the "Web HCatalog" Project has a problem to create the java-doc. After removing
this goal from the respective POM the compilation finishes without errors.
> 
> Anyway, i can not start hive now, even if i did not change the hive sourcecode at all
and only adapt the configuration file hive-site.xml (which worked prior to the update to the
new sources). Since there is no build-directory as it was given when hive was still compiled
with ant, i guess i should be able to go to $HIVE_HOME/bin and start the hive script.
> When i do, i get the message, that libraries are missing in the /lib folder. After copying
all hive jars there manually (is this meant to work that way?), i still can not start the
hive cli.
> 
> I tried to find answers on the net, in how far the building process has to be adapted
with the new sources, but i didnt find the solution for my problem.
> Can anybody please tell me, what i am missing here?
> 
> Thanks in advance,
> Björn-Elmar
> 
> 


Mime
View raw message